diff mbox series

[bug#39416,14/34] gnu: Add package r-ltm

Message ID 20200204135626.28261-14-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39416,01/34] gnu: Add package r-fracdiff | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Feb. 4, 2020, 1:56 p.m. UTC
* gnu/packages/cran.scm (r-ltm): New variable.
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8606695b7c..73dc753945 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19633,3 +19633,30 @@  observation schemes are supported.  Both Markov transition rates and the hidden
 Markov output process can be modelled in terms of covariates, which may be
 constant or piecewise-constant in time.")
     (license license:gpl2+)))
+
+(define-public r-ltm
+  (package
+    (name "r-ltm")
+    (version "1.1-1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "ltm" version))
+        (sha256
+          (base32
+            "1qrgzwx5l58qf5rfp1knxc84r0g943q5sdr3ky74zzwpnmrf2vf7"))))
+    (properties `((upstream-name . "ltm")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-mass" ,r-mass)
+        ("r-msm" ,r-msm)
+        ("r-polycor" ,r-polycor)))
+    (home-page "https://github.com/drizopoulos/ltm")
+    (synopsis "Latent Trait Models under IRT")
+    (description
+      "Analysis of multivariate dichotomous and polytomous data using latent
+trait models under the Item Response Theory approach.  It includes the Rasch,
+the Two-Parameter Logistic, the Birnbaum's Three-Parameter, the Graded
+Response, and the Generalized Partial Credit Models.")
+    (license license:gpl2+)))
+