diff mbox series

[bug#60901,03/25] gnu: Add go-golang-org-x-exp.

Message ID 20230118014510.19320-4-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:44 a.m. UTC
* gnu/packages/golang.scm (go-golang-org-x-exp): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

\( Feb. 6, 2023, 7:13 p.m. UTC | #1
* gnu/packages/golang.scm (go-golang-org-x-exp): New variable.

> @@ -2855,6 +2855,33 @@ (define-public go-github-com-hashicorp-hcl-v2

> +    (description
> +     "This subrepository holds experimental and deprecated (in the @code{old}
> +directory) packages.")

How about:

  (description
   "This package provides deprecated and experimental Go modules.")

instead?

    -- (
Katherine Cox-Buday Feb. 7, 2023, 4:28 p.m. UTC | #2
"( via Guix-patches" via <guix-patches@gnu.org> writes:

> * gnu/packages/golang.scm (go-golang-org-x-exp): New variable.
>
>> @@ -2855,6 +2855,33 @@ (define-public go-github-com-hashicorp-hcl-v2
>
>> +    (description
>> +     "This subrepository holds experimental and deprecated (in the @code{old}
>> +directory) packages.")
>
> How about:
>
>   (description
>    "This package provides deprecated and experimental Go modules.")
>
> instead?

Yes, that's better within the Guix context, IMO.

As a guide, I tend to take the package descriptions from upstream's
descriptions in an effort to provide packages that are as close to
upstream as possible. But this kind of conflicts with the ideal of a
distribution providing a curated, holistic, experience.

Should I give more weight to the latter, sometimes at the expense of the
former?
\( Feb. 7, 2023, 5:39 p.m. UTC | #3
On Tue Feb 7, 2023 at 4:28 PM GMT, Katherine Cox-Buday wrote:
> Should I give more weight to the latter, sometimes at the expense of the
> former?

IMO: definitely.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5e7fd1fa82..861640435e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2855,6 +2855,33 @@  (define-public go-github-com-hashicorp-hcl-v2
     (home-page "https://github.com/hashicorp/hcl")
     (license license:mpl2.0)))
 
+(define-public go-golang-org-x-exp
+  (package
+    (name "go-golang-org-x-exp")
+    (version "0.0.0-20221004215720-b9f4876ce741")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://go.googlesource.com/exp")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "030b929xyg8dpp6f4qbyg63msi6zgzj9sqmvnyphfcrjkqf7nr41"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "golang.org/x/exp"
+       ;; Source-only package
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (delete 'build))))
+    (home-page "https://golang.org/x/exp")
+    (synopsis "Experimental and deprecated Go packages")
+    (description
+     "This subrepository holds experimental and deprecated (in the @code{old}
+directory) packages.")
+    (license license:bsd-3)))
+
 (define-public go-golang-org-x-tools
   (let ((commit "8b927904ee0dec805c89aaf9172f4459296ed6e8")
         (revision "0"))