diff mbox series

[bug#60911,13/25] gnu: Add go-mvdan-cc-xurls.

Message ID 20230118014510.19320-14-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:44 a.m. UTC
* gnu/packages/golang.scm (go-mvdan-cc-xurls): New variable.
---
 gnu/packages/golang.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

\( Feb. 6, 2023, 10:34 p.m. UTC | #1
* gnu/packages/golang.scm (go-mvdan-cc-xurls): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -9792,6 +9792,20 @@ (define-public xurls

> +    (arguments
> +     `(#:import-path "mvdan.cc/xurls"
> +       #:tests? #f
> +       #:install-source? #t
> +       #:phases (modify-phases %standard-phases
> +                  (delete 'build))))

Agh, I didn't read this before the previous patch :)  I'm not sure whether you
could simplify their arguments, but I suspect you can; could you please have a
go?

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cabc2a4bab..2b778ac49e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9792,6 +9792,20 @@  (define-public xurls
 be used as both a binary and a library.")
     (license license:bsd-3)))
 
+(define-public go-mvdan-cc-xurls
+  (package
+    (inherit xurls)
+    (name "go-mvdan-cc-xurls")
+    (arguments
+     `(#:import-path "mvdan.cc/xurls"
+       #:tests? #f
+       #:install-source? #t
+       #:phases (modify-phases %standard-phases
+                  (delete 'build))))
+    (propagated-inputs (package-inputs xurls))
+    (native-inputs '())
+    (inputs '())))
+
 (define-public go-golang-org-x-lint
   (let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
         (revision "0"))