diff mbox series

[bug#60908,10/25] gnu: gopkg-in-errgo-fmt-errors: Rename package to go-gopkg-in-errgo-fmt-errors.

Message ID 20230118014510.19320-11-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:44 a.m. UTC
* gnu/packages/configuration-management.scm (chezmoi): Define in terms
of'go-gopkg-in-errgo-fmt-errors'.

* (go-gopkg-in-errgo-fmt-errors): New variable, formerly known as "gopkg-in-errgo-fmt-errors".
---
 gnu/packages/configuration-management.scm | 2 +-
 gnu/packages/golang.scm                   | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Christopher Baines Feb. 6, 2023, 10:17 p.m. UTC | #1
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

> * gnu/packages/configuration-management.scm (chezmoi): Define in terms
> of'go-gopkg-in-errgo-fmt-errors'.
>
> * (go-gopkg-in-errgo-fmt-errors): New variable, formerly known as "gopkg-in-errgo-fmt-errors".

I'm no expert in changelog entries in commit messages, but I'd probably
write this like:

* gnu/packages/golang.scm (gopkg-in-errgo-fmt-errors):
Rename to …
(go-gopkg-in-errgo-fmt-errors): … this.
* gnu/packages/configuration-management.scm (chezmoi)[native-inputs]: Update
accordingly.


I think that's a little clearer in terms of the changes being made, and
has less words as well.
\( Feb. 6, 2023, 10:22 p.m. UTC | #2
* gnu/packages/configuration-management.scm (chezmoi): Define in terms
of'go-gopkg-in-errgo-fmt-errors'.

* (go-gopkg-in-errgo-fmt-errors): New variable, formerly known as "gopkg-in-errgo-fmt-errors".

LGTM except for the commit message; please adopt Chris's suggestion :)

    -- (
Katherine Cox-Buday Feb. 7, 2023, 5:20 p.m. UTC | #3
Christopher Baines <mail@cbaines.net> writes:

> Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:
>
>> * gnu/packages/configuration-management.scm (chezmoi): Define in terms
>> of'go-gopkg-in-errgo-fmt-errors'.
>>
>> * (go-gopkg-in-errgo-fmt-errors): New variable, formerly known as
>> "gopkg-in-errgo-fmt-errors".
>
> I'm no expert in changelog entries in commit messages, but I'd probably
> write this like:
>
> * gnu/packages/golang.scm (gopkg-in-errgo-fmt-errors):
> Rename to …
> (go-gopkg-in-errgo-fmt-errors): … this.
> * gnu/packages/configuration-management.scm (chezmoi)[native-inputs]: Update
> accordingly.
>
>
> I think that's a little clearer in terms of the changes being made,
> and has less words as well.

Thank you for the suggestions; I agree it is much clearer.

The changelog format is something I personally really struggle with, so
I use tools to hopefully get me closer to being correct. I am using the
auto-complete snippets provided `./etc/snippets`, and it looks like this
is the format defined in:

`./etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package`

I'd love to be able to get these right, and I'll endeavor to do so, but
if the tooling is suggesting unhelpful things, it's going to be a real
struggle for me. Should we update the snippets?
Christopher Baines Feb. 8, 2023, 11:45 a.m. UTC | #4
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:
>>
>>> * gnu/packages/configuration-management.scm (chezmoi): Define in terms
>>> of'go-gopkg-in-errgo-fmt-errors'.
>>>
>>> * (go-gopkg-in-errgo-fmt-errors): New variable, formerly known as
>>> "gopkg-in-errgo-fmt-errors".
>>
>> I'm no expert in changelog entries in commit messages, but I'd probably
>> write this like:
>>
>> * gnu/packages/golang.scm (gopkg-in-errgo-fmt-errors):
>> Rename to …
>> (go-gopkg-in-errgo-fmt-errors): … this.
>> * gnu/packages/configuration-management.scm (chezmoi)[native-inputs]: Update
>> accordingly.
>>
>>
>> I think that's a little clearer in terms of the changes being made,
>> and has less words as well.
>
> Thank you for the suggestions; I agree it is much clearer.
>
> The changelog format is something I personally really struggle with, so
> I use tools to hopefully get me closer to being correct. I am using the
> auto-complete snippets provided `./etc/snippets`, and it looks like this
> is the format defined in:
>
> `./etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package`
>
> I'd love to be able to get these right, and I'll endeavor to do so, but
> if the tooling is suggesting unhelpful things, it's going to be a real
> struggle for me. Should we update the snippets?

I also struggle with this, so I'm don't really have any great
suggestions. If you think the snippets could be improved, then that
sounds great to me.
diff mbox series

Patch

diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 3ebb6957c8..b66f70545a 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -97,7 +97,7 @@  (define-public chezmoi
            go-golang-org-x-net
            go-golang-org-x-oauth2
            go-github-com-rogpeppe-go-internal
-           gopkg-in-errgo-fmt-errors))
+           go-gopkg-in-errgo-fmt-errors))
     (home-page "https://www.chezmoi.io/")
     (synopsis "Personal configuration files manager")
     (description "This package helps to manage personal configuration files
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 240f8ea56c..4cef0f61f6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9147,9 +9147,9 @@  (define-public go-github-com-rogpeppe-go-internal
 @end itemize\n")
     (license license:bsd-3)))
 
-(define-public gopkg-in-errgo-fmt-errors
+(define-public go-gopkg-in-errgo-fmt-errors
   (package
-    (name "gopkg-in-errgo-fmt-errors")
+    (name "go-gopkg-in-errgo-fmt-errors")
     (version "2.1.0")
     (source (origin
               (method git-fetch)
@@ -9162,7 +9162,7 @@  (define-public gopkg-in-errgo-fmt-errors
                 "065mbihiy7q67wnql0bzl9y1kkvck5ivra68254zbih52jxwrgr2"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "gopkg.in/errgo.v2/fmt/errors"
+     `(#:import-path "gopkg.in/errgo.v2"
        #:tests? #f
        ;; Source-only package
        #:phases