diff mbox series

[bug#60900,04/25] gnu: Add go-github-com-jba-printsrc.

Message ID 20230118014510.19320-5-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:44 a.m. UTC
* gnu/packages/golang.scm (go-github-com-jba-printsrc): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

\( Feb. 6, 2023, 7:15 p.m. UTC | #1
* gnu/packages/golang.scm (go-github-com-jba-printsrc): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -8515,6 +8515,32 @@ (define-public go-github-com-go-git-go-billy

> +    (arguments
> +     '(#:import-path "github.com/jba/printsrc"
> +       ;; TODO: Open bug; expecting time.Local, but when local=UTC, we get time.UTC

Please add the bug report URL.

> +    (description
> +     "Package printsrc prints Go values as Go source.  It strives to render
> +legal Go source code, and returns an error when detects that it cannot.")

  (description
   "This package provides a Go library for printing Go values as legal source 
  code, and attempts to detect when this is not possible."

> +    ;; MIT

Redundant comment :)

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 861640435e..677d58d831 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8515,6 +8515,32 @@  (define-public go-github-com-go-git-go-billy
 file system operations.")
     (license license:asl2.0)))
 
+(define-public go-github-com-jba-printsrc
+  (package
+    (name "go-github-com-jba-printsrc")
+    (version "0.2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jba/printsrc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gyy3kmb5a5i710wkv3b7ah7i7sz5sdc7v3sab5m4rxch1sd2fpj"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/jba/printsrc"
+       ;; TODO: Open bug; expecting time.Local, but when local=UTC, we get time.UTC
+       #:tests? #f))
+    (home-page "https://github.com/jba/printsrc")
+    (synopsis "Prints Go values as sourcecode")
+    (description
+     "Package printsrc prints Go values as Go source.  It strives to render
+legal Go source code, and returns an error when detects that it cannot.")
+    ;; MIT
+    (license license:expat)))
+
 (define-public go-github-com-jbenet-go-context
   (let ((commit "d14ea06fba99483203c19d92cfcd13ebe73135f4")
         (revision "1"))