diff mbox series

[bug#60917,21/25] gnu: go-github-com-burntsushi-toml: Update to 1.2.1.

Message ID 20230118014510.19320-22-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:45 a.m. UTC
* gnu/packages/golang.scm (go-github-com-burntsushi-toml): Update to 1.2.1.
---
 gnu/packages/golang.scm | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

Comments

\( Feb. 6, 2023, 11:12 p.m. UTC | #1
* gnu/packages/golang.scm (go-github-com-burntsushi-toml): Update to 1.2.1.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -3328,23 +3328,23 @@ (define-public go-golang-org-x-mod

>      (synopsis "Toml parser and encoder for Go")

  (synopsis "Parsing for TOML in Go")

> +    (description
> +     "This package is toml parser and encoder for Go.  The interface
>  is similar to Go's standard library @code{json} and @code{xml} package.")

  (description
   "This package provides a Go library for parsing the TOML configuration
  language, similar to the standard @code{json} and @code{xml} packages.")

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 26cd636c64..660deceec5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3328,23 +3328,23 @@  (define-public go-golang-org-x-mod
 (define-public go-github-com-burntsushi-toml
   (package
     (name "go-github-com-burntsushi-toml")
-    (version "0.3.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/BurntSushi/toml")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "1fjdwwfzyzllgiwydknf1pwjvy49qxfsczqx5gz3y0izs7as99j6"))))
+    (version "1.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/BurntSushi/toml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1v9czq4hsyvdz7yx70y6sgq77wmrgfmn09r9cj4w85z38jqnamv7"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/BurntSushi/toml"))
     (home-page "https://github.com/BurntSushi/toml")
     (synopsis "Toml parser and encoder for Go")
-    (description "This package is toml parser and encoder for Go.  The interface
+    (description
+     "This package is toml parser and encoder for Go.  The interface
 is similar to Go's standard library @code{json} and @code{xml} package.")
     (license license:expat)))