diff mbox series

[bug#60918,19/25] gnu: Add govulncheck.

Message ID 20230118014510.19320-20-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:45 a.m. UTC
* gnu/packages/golang.scm (govulncheck): New variable.
---
 gnu/packages/golang.scm | 51 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)

Comments

Christopher Baines Feb. 6, 2023, 10:52 p.m. UTC | #1
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

> * gnu/packages/golang.scm (govulncheck): New variable.
> ---
>  gnu/packages/golang.scm | 51 +++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 51 insertions(+)

...

> +    (description
> +     "This repository contains packages for accessing and analyzing data from the
> +@@url{https://vuln.go.dev,Go Vulnerability Database}.  It contains the
> +following:")

I've cut the second incomplete sentance out, and also fixed the @url bit
(just one @, you can test this with guix show).
\( Feb. 6, 2023, 11:10 p.m. UTC | #2
* gnu/packages/golang.scm (govulncheck): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -2956,6 +2956,57 @@ (define-public go-golang-org-x-crypto

> +    (version "0.0.0-20221229164908-ebf31f7dc3ef")

Please use git-version.

> +    (arguments
> +     `(#:import-path "golang.org/x/vuln"
> +       #:go ,go-1.19
> +       #:install-source? #f
> +       #:phases ,#~(modify-phases %standard-phases
> +                     (add-after 'unpack 'remove-go-mod-tidy
> +                       (lambda _
> +                         (substitute* "src/golang.org/x/vuln/checks.bash"
> +                           (("go mod tidy")
> +                            #$(file-append coreutils-minimal "/bin/true")))))
> +                     (replace 'build
> +                       (lambda arguments
> +                         (apply (assoc-ref %standard-phases
> +                                           'build)
> +                                `(,@arguments #:import-path
> +                                  "golang.org/x/vuln/cmd/govulncheck")))))))

Please try to see if you can remove ``(replace 'build ...)'' et cetera.

> +    (synopsis "Go Vulnerability Management")

  (synopsis "Manage data from the Go Vulnerability Database")

> +    (description
> +     "This repository contains packages for accessing and analyzing data from the
> +@@url{https://vuln.go.dev,Go Vulnerability Database}.  It contains the
> +following:")

  (description
   "This package provides a Go library and program for accessing and analysing
  data from the @url{https://vuln.go.dev, Go Vulnerability Database.")

    -- (
Katherine Cox-Buday Feb. 7, 2023, 5:56 p.m. UTC | #3
Christopher Baines <mail@cbaines.net> writes:

> Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:
>
>> * gnu/packages/golang.scm (govulncheck): New variable.
>> ---
>>  gnu/packages/golang.scm | 51 +++++++++++++++++++++++++++++++++++++++++
>>  1 file changed, 51 insertions(+)
>
> ...
>
>> +    (description
>> +     "This repository contains packages for accessing and analyzing data from the
>> +@@url{https://vuln.go.dev,Go Vulnerability Database}.  It contains the
>> +following:")
>
> I've cut the second incomplete sentance out, and also fixed the @url bit
> (just one @, you can test this with guix show).

Thanks, and sorry. I'll update my local tooling to try and start
checking for this.

I think this must have been `guix import go`? It might have a bug that
adds an extra `@`, because I don't recall adding the description for
this package.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index eaff0dfc37..f135b2717f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2956,6 +2956,57 @@  (define-public go-golang-org-x-crypto
       (home-page "https://go.googlesource.com/crypto/")
       (license license:bsd-3))))
 
+(define-public govulncheck
+  (package
+    (name "govulncheck")
+    (version "0.0.0-20221229164908-ebf31f7dc3ef")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://go.googlesource.com/vuln")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1w055g90k7anrrcvfrsqklxzl9pl0vqdiwpayj9f0brwys9xhj7d"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "golang.org/x/vuln"
+       #:go ,go-1.19
+       #:install-source? #f
+       #:phases ,#~(modify-phases %standard-phases
+                     (add-after 'unpack 'remove-go-mod-tidy
+                       (lambda _
+                         (substitute* "src/golang.org/x/vuln/checks.bash"
+                           (("go mod tidy")
+                            #$(file-append coreutils-minimal "/bin/true")))))
+                     (replace 'build
+                       (lambda arguments
+                         (apply (assoc-ref %standard-phases
+                                           'build)
+                                `(,@arguments #:import-path
+                                  "golang.org/x/vuln/cmd/govulncheck")))))))
+    (native-inputs (list coreutils-minimal))
+    (inputs (list go-golang-org-x-sys
+                  go-github-com-google-renameio
+                  go-github-com-burntsushi-toml
+                  go-mvdan-cc-unparam
+                  go-honnef-co-go-tools
+                  go-golang-org-x-tools
+                  go-golang-org-x-sync
+                  go-golang-org-x-mod
+                  go-golang-org-x-exp
+                  go-github-com-google-go-cmp-cmp
+                  go-github-com-google-go-cmdtest
+                  go-github-com-client9-misspell))
+    (home-page "https://golang.org/x/vuln")
+    (synopsis "Go Vulnerability Management")
+    (description
+     "This repository contains packages for accessing and analyzing data from the
+@@url{https://vuln.go.dev,Go Vulnerability Database}.  It contains the
+following:")
+    (license license:bsd-3)))
+
 (define-public go-github-com-protonmail-go-crypto
   (package
     (name "go-github-com-protonmail-go-crypto")