diff mbox series

[bug#60914,15/25] gnu: Add go-github-com-client9-misspell.

Message ID 20230118014510.19320-16-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:45 a.m. UTC
* gnu/packages/golang.scm (go-github-com-client9-misspell): New variable.
---
 gnu/packages/golang.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

\( Feb. 6, 2023, 10:36 p.m. UTC | #1
* gnu/packages/golang.scm (go-github-com-client9-misspell): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -4850,6 +4850,20 @@ (define-public misspell

> +    (arguments
> +     `(#:import-path "github.com/client9/misspell"
> +       #:tests? #f
> +       #:install-source? #t
> +       #:phases (modify-phases %standard-phases
> +                  (delete 'build))))

Same comment as the last-but-one.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b84fe59503..fe45b29215 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4850,6 +4850,20 @@  (define-public misspell
      "Package misspell corrects commonly misspelled English words in source files.")
     (license license:expat)))
 
+(define-public go-github-com-client9-misspell
+  (package
+    (inherit misspell)
+    (name "go-github-com-client9-misspell")
+    (arguments
+     `(#:import-path "github.com/client9/misspell"
+       #:tests? #f
+       #:install-source? #t
+       #:phases (modify-phases %standard-phases
+                  (delete 'build))))
+    (propagated-inputs (package-inputs misspell))
+    (native-inputs '())
+    (inputs '())))
+
 (define-public go-github-com-stevedonovan-luar
   (let ((commit "22d247e5366095f491cd83edf779ee99a78f5ead")
         (revision "0"))