diff mbox series

[bug#60907,07/25] gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.

Message ID 20230118014510.19320-8-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:44 a.m. UTC
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Update to 0.5.9.
---
 gnu/packages/golang.scm | 21 ++++++++++-----------
 1 file changed, 10 insertions(+), 11 deletions(-)

Comments

\( Feb. 6, 2023, 10:20 p.m. UTC | #1
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Update to 0.5.9.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -7024,28 +7024,27 @@ (define-public go-github-com-fatih-color

> +    (description
> +     "This package is intended to be a more powerful and safer
> +alternative to @@code{reflect.DeepEqual} for comparing whether two values are
> +semantically equal.")

This is a full sentence, but it doesn't really read well to me.  Also, there
should only be one ``@'' in ``@code{...}'', and "more powerful and safer" is
a bit vague :)

What about this?:

  (description
   "This package provides an alternative to the built-in @code{reflect.DeepEqual}
  function for checking if two values are semantically equal.  The advantages
  over the builtin function include:

  @enumerate
  [etc etc :)]
  @end enumerate")

    -- (
Katherine Cox-Buday Feb. 7, 2023, 5:28 p.m. UTC | #2
"( via Guix-patches" via <guix-patches@gnu.org> writes:

> * gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Update to 0.5.9.
>
>> --- a/gnu/packages/golang.scm
>> +++ b/gnu/packages/golang.scm
>
>> @@ -7024,28 +7024,27 @@ (define-public go-github-com-fatih-color
>
>> +    (description
>> +     "This package is intended to be a more powerful and safer
>> +alternative to @@code{reflect.DeepEqual} for comparing whether two values are
>> +semantically equal.")
>
> This is a full sentence, but it doesn't really read well to me. Also,
> there should only be one ``@'' in ``@code{...}'', and "more powerful
> and safer" is a bit vague :)

I'd only intended this to be a version bump. Maybe I updated the
description based on feedback from `guix style` or `guix lint`.

At any rate, I agree the description is not very helpful, and uses
superlatives, which the manual calls out as an anti-pattern.

>
> What about this?:
>
>   (description
>    "This package provides an alternative to the built-in @code{reflect.DeepEqual}
>   function for checking if two values are semantically equal.  The advantages
>   over the builtin function include:
>
>   @enumerate
>   [etc etc :)]
>   @end enumerate")

I like this much more, although I don't know enough about it to
enumerate the benefits. If I can discover those, I'll enumerate them :)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aabaa6336c..9554234c7b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7024,28 +7024,27 @@  (define-public go-github-com-fatih-color
 (define-public go-github-com-google-go-cmp-cmp
   (package
     (name "go-github-com-google-go-cmp-cmp")
-    (version "0.5.2")
+    (version "0.5.9")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/google/go-cmp")
-                     (commit (string-append "v" version))))
+                    (url "https://github.com/google/go-cmp")
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0qchy411jm9q2l9mf7x3ry2ycaqp9xdhf2nx14qrpzcxfigv2705"))))
+                "0a13m7l1jrysa7mrlmra8y7n83zcnb23yjyg3a609p8i9lxkh1wm"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/google/go-cmp/cmp"
        #:unpack-path "github.com/google/go-cmp"))
-    (propagated-inputs
-     (list go-golang-org-x-xerrors))
     (synopsis "Determine equality of values in Go")
-    (description "This package provides a more powerful and safer
-alternative to @code{reflect.DeepEqual} for comparing whether two values
-are semantically equal in Go (for writing tests).")
-    (home-page "https://godoc.org/github.com/google/go-cmp/cmp")
-    (license license:asl2.0)))
+    (description
+     "This package is intended to be a more powerful and safer
+alternative to @@code{reflect.DeepEqual} for comparing whether two values are
+semantically equal.")
+    (home-page "https://github.com/google/go-cmp")
+    (license license:bsd-3)))
 
 (define-public go-github-com-google-uuid
   (package