diff mbox series

[bug#60920,22/25] gnu: go-honnef-co-go-tools: Update to 0.3.3.

Message ID 20230118014510.19320-23-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:45 a.m. UTC
* gnu/packages/golang.scm (go-honnef-co-go-tools): Update to 0.3.3.
---
 gnu/packages/golang.scm | 31 +++++++++++++++----------------
 1 file changed, 15 insertions(+), 16 deletions(-)

Comments

\( Feb. 6, 2023, 11:15 p.m. UTC | #1
* gnu/packages/golang.scm (go-honnef-co-go-tools): Update to 0.3.3.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -10008,27 +10008,26 @@ (define-public go-github-com-kisielk-gotool

> +    (propagated-inputs (list go-golang-org-x-exp go-golang-org-x-tools
> +                             go-golang-org-x-mod go-github-com-kisielk-gotool
> +                             go-github-com-burntsushi-toml))

Add newlines between the inputs.

>      (synopsis "Staticcheck advanced Go linter")

Please change this to:

  (synopsis "Static linter for Go code")

>      (description

I don't know what the description here is, but could you try to improve it
too if necessary?

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 660deceec5..97f1753f42 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10008,27 +10008,26 @@  (define-public go-github-com-kisielk-gotool
 (define-public go-honnef-co-go-tools
   (package
     (name "go-honnef-co-go-tools")
-    (version "0.1.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/dominikh/go-tools")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "17li8jbw3cpn59kpcl3j3r2an4wkx3fc81xn0j4xgbjpkxh9493n"))))
+    (version "0.3.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dominikh/go-tools")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "099z04v7vvwwglnps315s9fmal68xvzlc1g8m26iqi980grbwn32"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "honnef.co/go/tools"
        #:tests? #f
        ;; Source-only package
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'build))))
-    (propagated-inputs
-     (list go-golang-org-x-tools go-github-com-kisielk-gotool
-           go-github-com-burntsushi-toml))
+       #:phases (modify-phases %standard-phases
+                  (delete 'build))))
+    (propagated-inputs (list go-golang-org-x-exp go-golang-org-x-tools
+                             go-golang-org-x-mod go-github-com-kisielk-gotool
+                             go-github-com-burntsushi-toml))
     (home-page "https://honnef.co/go/tools")
     (synopsis "Staticcheck advanced Go linter")
     (description