diff mbox series

[bug#60912,14/25] gnu: Add misspell.

Message ID 20230118014510.19320-15-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:44 a.m. UTC
* gnu/packages/golang.scm (misspell): New variable.
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

\( Feb. 6, 2023, 10:35 p.m. UTC | #1
* gnu/packages/golang.scm (misspell): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -4821,6 +4821,35 @@ (define-public go-gitlab-com-ambrevar-damerau

> +    (arguments
> +     '(#:import-path "github.com/client9/misspell"
> +       #:phases (modify-phases %standard-phases
> +                  (replace 'build
> +                    (lambda arguments
> +                      (apply (assoc-ref %standard-phases
> +                                        'build)
> +                             `(,@arguments #:import-path
> +                               "github.com/client9/misspell/cmd/misspell")))))))

Same comment on this arguments field as the last two.

> +    (synopsis "Install")

Um... :)

> +    (description
> +     "Package misspell corrects commonly misspelled English words in source files.")

s/Package misspell/This package/

    -- (
Christopher Baines Feb. 6, 2023, 10:36 p.m. UTC | #2
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:

> * gnu/packages/golang.scm (misspell): New variable.
> ---
>  gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)

...

> +    (synopsis "Install")
> +    (description
> +     "Package misspell corrects commonly misspelled English words in source files.")

I've changed this to:

    (synopsis "Correct commonly misspelled English words in source files")
    (description
     "misspell assists with correcting commonly misspelled English words in
source files.  A neutral variety of English is used by default, but a US or UK
locale can be selected.")
Katherine Cox-Buday Feb. 7, 2023, 5:53 p.m. UTC | #3
Christopher Baines <mail@cbaines.net> writes:

> Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:
>
>> * gnu/packages/golang.scm (misspell): New variable.
>> ---
>>  gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
>>  1 file changed, 29 insertions(+)
>
> ...
>
>> +    (synopsis "Install")
>> +    (description
>> +     "Package misspell corrects commonly misspelled English words in source files.")

Oh jees! Sorry about that! My best guess is that I was typing in another
window, nudged the mouse, and then `guix style` capitalized it.

> I've changed this to:
>
>     (synopsis "Correct commonly misspelled English words in source files")
>     (description
>      "misspell assists with correcting commonly misspelled English words in
> source files.  A neutral variety of English is used by default, but a US or UK
> locale can be selected.")

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2b778ac49e..b84fe59503 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4821,6 +4821,35 @@  (define-public go-gitlab-com-ambrevar-damerau
 similar word.")
       (license license:expat))))
 
+(define-public misspell
+  (package
+    (name "misspell")
+    (version "0.3.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/client9/misspell")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vwf33wsc4la25zk9nylpbp9px3svlmldkm0bha4hp56jws4q9cs"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/client9/misspell"
+       #:phases (modify-phases %standard-phases
+                  (replace 'build
+                    (lambda arguments
+                      (apply (assoc-ref %standard-phases
+                                        'build)
+                             `(,@arguments #:import-path
+                               "github.com/client9/misspell/cmd/misspell")))))))
+    (home-page "https://github.com/client9/misspell")
+    (synopsis "Install")
+    (description
+     "Package misspell corrects commonly misspelled English words in source files.")
+    (license license:expat)))
+
 (define-public go-github-com-stevedonovan-luar
   (let ((commit "22d247e5366095f491cd83edf779ee99a78f5ead")
         (revision "0"))