diff mbox series

[bug#60913,16/25] gnu: Add go-github-com-google-go-cmdtest.

Message ID 20230118014510.19320-17-cox.katherine.e@gmail.com
State New
Headers show
Series gnu: golang: Add gopls | expand

Commit Message

Katherine Cox-Buday Jan. 18, 2023, 1:45 a.m. UTC
* gnu/packages/golang.scm (go-github-com-google-go-cmdtest): New variable.
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

\( Feb. 6, 2023, 11:05 p.m. UTC | #1
* gnu/packages/golang.scm (go-github-com-google-go-cmdtest): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -11044,6 +11044,35 @@ (define-public go-github-com-google-go-jsonnet

> +      (synopsis "Testing your CLI")

  (synopsis "Test Go command line tools")

> +      (description
> +       "The cmdtest package simplifies testing of command-line interfaces.  It provides
> +a simple, cross-platform, shell-like language to express command execution.  It
> +can compare actual output with the expected output, and can also update a file
> +with new \"golden\" output that is deemed correct.")

  (description
   "This package provides a Go library to simplify the testing of @acronym{CLI}s.")

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fe45b29215..ced6438581 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11044,6 +11044,35 @@  (define-public go-github-com-google-go-jsonnet
 implementation.")
     (license license:asl2.0)))
 
+(define-public go-github-com-google-go-cmdtest
+  (let ((commit "55ab3332a786118933ddf71544aae14951ba9bc5")
+        (revision "0"))
+    (package
+      (name "go-github-com-google-go-cmdtest")
+      (version (git-version "0.4.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/google/go-cmdtest")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "10kswvbdwissjb5mr0ys4b3ppxkxlpklqg7cr2z7rv21g2vwczbl"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/google/go-cmdtest"))
+      (propagated-inputs (list go-github-com-google-renameio
+                               go-github-com-google-go-cmp-cmp))
+      (home-page "https://github.com/google/go-cmdtest")
+      (synopsis "Testing your CLI")
+      (description
+       "The cmdtest package simplifies testing of command-line interfaces.  It provides
+a simple, cross-platform, shell-like language to express command execution.  It
+can compare actual output with the expected output, and can also update a file
+with new \"golden\" output that is deemed correct.")
+      (license license:asl2.0))))
+
 (define-public go-github-com-google-safehtml
   (package
     (name "go-github-com-google-safehtml")