diff mbox series

[bug#63139,python,19/20] gnu: Add python-makefun.

Message ID e032ff32fdf77091fd265bff861ef078d0fd14fe.1682660105.git.john.kehayias@protonmail.com
State New
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Commit Message

John Kehayias April 28, 2023, 5:52 a.m. UTC
* gnu/packages/python-xyz.scm (python-makefun): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e468844ff6..94c0e1ab81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24905,6 +24905,24 @@  (define-public python-construct
 make your work easier.")
     (license license:expat)))

+(define-public python-makefun
+  (package
+    (name "python-makefun")
+    (version "1.15.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "makefun" version))
+              (sha256
+               (base32
+                "19a8dga8rnmjn5gy1cy1wdi28swbkdkypwbqikbxil6ynqcg3c20"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools-scm python-pytest))
+    (home-page "https://smarie.github.io/python-makefun")
+    (synopsis "Small library to dynamically create Python functions.")
+    (description "A library to dynamically create Python functions with a
+proper signature.")
+    (license license:bsd-3)))
+
 (define-public python-outcome
   (package
     (name "python-outcome")