diff mbox series

[bug#63139,python,16/20] gnu: Add python-poetry-plugin-export.

Message ID 076c78c91cfd2c25477226c20cb2f04b31f98d13.1682660105.git.john.kehayias@protonmail.com
State New
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Commit Message

John Kehayias April 28, 2023, 5:51 a.m. UTC
* gnu/packages/python-xyz.scm (python-poetry-plugin-export): New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cbe3bb1094..e468844ff6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18133,6 +18133,35 @@  (define-public python-deepdiff
 for objects within other objects and DeepHash to hash any object.")
     (license license:expat)))

+(define-public python-poetry-plugin-export
+  (package
+    (name "python-poetry-plugin-export")
+    (version "1.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "poetry_plugin_export" version))
+              (sha256
+               (base32
+                "115zx9nqjbzpgj4akz9g5rzpd2pdykxbz584h6sz19d8awkp8jfr"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list poetry
+                         python-poetry-core
+                         python-pytest
+                         python-pytest-mock
+                         python-pytest-xdist))
+    (propagated-inputs (list python-pypa-build python-cachy python-pendulum))
+    (home-page "https://github.com/python-poetry/poetry-plugin-export")
+    (synopsis "Poetry plugin to export the dependencies to various formats")
+    (description "This package is a plugin for Poetry that allows the export
+of locked packages to various formats.
+
+Note: For now, only the @code{constraints.txt} and @code{requirements.txt}
+formats are available.
+
+This plugin provides the same features as the existing export command of
+Poetry which it will eventually replace.")
+    (license license:expat)))
+
 (define-public poetry
   (package
     (name "poetry")