diff mbox series

[bug#63139,python,12/20] gnu: python-jsonschema: Update to 4.17.3.

Message ID 828fa92ac1fdc3647bbb6bf0a4dc55dee1cf578a.1682660105.git.john.kehayias@protonmail.com
State New
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Commit Message

John Kehayias April 28, 2023, 5:51 a.m. UTC
* gnu/packages/python-xyz.scm (python-jsonschema): Update to 4.17.3.
[native-inputs]: Remove python-setuptools-scm.  Add
python-hatch-fancy-pypi-readme, python-hatch-vcs, and python-hatchling.
---
 gnu/packages/python-xyz.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 674420c0c4..a3ed048f03 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4081,15 +4081,13 @@  (define-public python-jsondiff
 (define-public python-jsonschema
   (package
     (name "python-jsonschema")
-    ;; XXX: Update to the latest version requires new build system - Hatch
-    ;; https://hatch.pypa.io/
-    (version "4.5.1")
+    (version "4.17.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "jsonschema" version))
        (sha256
-        (base32 "1z0x22691jva7lwfcfh377jdmlz68zhiawxzl53k631l34k8hvbw"))))
+        (base32 "03dnxhvzfxmnpn53zsc0598hsslaz7w3wi87cyx7cq4bmcvl91hg"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -4106,7 +4104,10 @@  (define-public python-jsonschema
               (when tests?
                 (setenv "JSON_SCHEMA_TEST_SUITE" "json")
                 (invoke "trial" "jsonschema")))))))
-    (native-inputs (list python-setuptools-scm python-twisted))
+    (native-inputs (list python-hatch-fancy-pypi-readme
+                         python-hatch-vcs
+                         python-hatchling
+                         python-twisted))
     (propagated-inputs
      (list python-attrs
            python-importlib-metadata