diff mbox series

[bug#63139,python,07/20] gnu: python-platformdirs: Update to 3.2.0.

Message ID 7a4f03ad5860bc8c607074e62482836599d4fe32.1682660104.git.john.kehayias@protonmail.com
State New
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Commit Message

John Kehayias April 28, 2023, 5:50 a.m. UTC
* gnu/packages/python-xyz.scm (python-platformdirs): Update to 3.2.0.
[build-system]: Switch to pyproject-build-system.
[arguments]: Remove 'check' phase.
[native-inputs]: Add python-hatch-vcs and python-hatchling.  Remove
python-setuptools-scm.
---
 gnu/packages/python-xyz.scm | 19 ++++++++-----------
 1 file changed, 8 insertions(+), 11 deletions(-)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 95eea4ecf2..46ceb1583b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29928,23 +29928,20 @@  (define-public python-stripe
 (define-public python-platformdirs
   (package
     (name "python-platformdirs")
-    (version "2.4.1")
+    (version "3.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "platformdirs" version))
        (sha256
-        (base32 "1njz0h4iky8iglrb85cd07hpa3lp1a2dfr934dj65hxwzvfk61j4"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "pytest" "-vv")))))))
+        (base32 "021bdjqy29vvyl1qkcha07mdf0sr6gdqkxqg6mwzj9bz7753idnm"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-appdirs python-pytest python-pytest-mock
-           python-setuptools-scm))
+     (list python-appdirs
+           python-hatch-vcs
+           python-hatchling
+           python-pytest
+           python-pytest-mock))
     (home-page "https://github.com/platformdirs/platformdirs")
     (synopsis "Determine the appropriate platform-specific directories")
     (description "When writing applications, finding the right location to