mbox series

[bug#63139,python,00/20] Updates for pyproject-build-system, poetry, python-yubikey-manager

Message ID cover.1682660104.git.john.kehayias@protonmail.com
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Message

John Kehayias April 28, 2023, 5:44 a.m. UTC
Hi Guix and Python team,

Here is a patch series where the original goal was to fix python-yubikey-manager on core-updates and then ballooned to a bit more. This should be done in a feature branch for Python.

Mostly this was to fix/update the needed dependencies, though it may be possible to do this in a more minimal way just for that package fix. Anyway, I tried to generate this series in a way that each patch continues to fix things, but due to the complicated dependencies this may not be perfect.

A few notes:

1. Most of the series is pretty trivial, quick fixes/updates, some new packages.

2. What isn't is a few cases of failing tests which weren't immediately obvious to me and likely were some network access and/or build environment details. Some could be worked around maybe if someone wants to try (e.g. in python-virtualenv). I did enable more tests along the way though (like for poetry), so on the whole I think this is a step forward.

3. The dependents tend to be maybe 10s, a few in the hundreds, and then about 3k for python-filelock. Until we get to pyproject-build-system updates:

4. I believe it was poetry that needed a newer python-pypa-build module, which then touches all pyproject-build-system (about 6k packages). This isn't strictly necessary as we could have a newer and separate package for leafs to use rather than in the build system as well, but I figured might as well do it sooner rather than later. At least the packages up to python-yubikey-manager built with this along with some random others.

5. On that note, I did not complete this change as I wanted some feedback on the bootstraping. I've added python-pyproject-hooks which should deprecate pep517, but currently it also needs python-pypa-build. I've made the older python-pypa-build a -bootstrap package to build this and the newer version of itself as well. So I did not deprecate pep517 yet.

   Also, python-wheel was a propagated-input in pep517 which is not needed in pyproject-hooks. However, I saw at least some packages will then need that as an input to build; so I kept it for pyproject-hooks to ease testing. It should be removed and added as an input as needed (no idea if that is just a few or a lot of the tree).

Okay, I think those are my notes. We should see what other things are ready to be made into this feature branch for Python. One brought to my attention recently is https://issues.guix.gnu.org/63044 though I have not looked at it.

Thanks!
John

John Kehayias (20):
  gnu: Add python-installer.
  gnu: Add python-pyproject-hooks.
  gnu: Add python-rapidfuzz.
  gnu: python-crashtest: Update to 0.4.1.
  gnu: python-cleo: Update to 2.0.1.
  gnu: Add python-deepdiff.
  gnu: python-platformdirs: Update to 3.2.0.
  gnu: python-filelock: Update to 3.12.0.
  gnu: python-distlib: Update to 0.3.6.
  gnu: python-virtualenv: Update to 20.22.0.
  gnu: python-pkginfo: Update to 1.9.6.
  gnu: python-jsonschema: Update to 4.17.3.
  gnu: python-dulwich: Update to 0.21.3.
  gnu: Update python-pypa-build to 1.0.0.
  gnu: poetry: Fix build.
  gnu: Add python-poetry-plugin-export.
  gnu: python-pyscard: Update to 2.0.7.
  gnu: python-fido2: Update to 1.1.1 and enable tests.
  gnu: Add python-makefun.
  gnu: python-yubikey-manager: Update to 5.1.0 and enable tests.

 gnu/packages/python-build.scm   |  80 +++++++-
 gnu/packages/python-xyz.scm     | 319 +++++++++++++++++++++++++-------
 gnu/packages/security-token.scm |  61 +++---
 3 files changed, 370 insertions(+), 90 deletions(-)


base-commit: aecc6e70587f8412cbbb9b2c13141de4f534518e
--
2.39.2

Comments

Reza Housseini June 22, 2023, 7:06 a.m. UTC | #1
Hi

Poetry is not building on ci.guix.gnu.org [1]. There is a pending patch 
[2] on the issue tracker. What is missing to apply this patch and how 
can I help?

Cheers,
Reza

[1] https://ci.guix.gnu.org/search?query=poetry
[2] https://issues.guix.gnu.org/63139

-- 
Reza Housseini

This message is signed with my GnuPG key:

     C0F3 0812 9AF2 80F4 0830 C2C1 C375 C6AF 0512 5C52
Sharlatan Hellseher Feb. 2, 2024, 8:43 p.m. UTC | #2
Hello,

Gentle ping on this issue.

Lets check it out on python-team branch?
I can volunteer myself to resolve dependence cycles ;-)

Thanks,
Oleg
John Kehayias Feb. 14, 2024, 6:41 p.m. UTC | #3
Hi Oleg,

On Fri, Feb 02, 2024 at 08:43 PM, Sharlatan Hellseher wrote:

> Hello,
>
> Gentle ping on this issue.
>

Your message looks like it was just sent to the debbugs number, which
doesn't reach any humans (as far as I know); it is not a mailing list.
Confusing, and who knows how many messages have not been seen because of
that.

Anyway, CC'ing Lars since there was a mention of some WIP patches on a
off guix branch.

> Lets check it out on python-team branch?
> I can volunteer myself to resolve dependence cycles ;-)
>

Thanks for the volunteering, I guess we should see what the status is
with whatever Lars got up to before and see what is next.

John
Lars-Dominik Braun Feb. 16, 2024, 12:44 p.m. UTC | #4
Hi,

> Anyway, CC'ing Lars since there was a mention of some WIP patches on a
> off guix branch.

the patches from #65001 have been merged into the python-team
branch. That should fix the first four steps from my proposal at
https://issues.guix.gnu.org/issue/63139#23 and allow us to properly
bootstrap the required packages and in the end also fix
python-yubikey-manager.

Cheers,
Lars