diff mbox series

[bug#63139,python,01/20] gnu: Add python-installer.

Message ID 0504e49b958ab84da4ca632c243d5072c7b9862f.1682660104.git.john.kehayias@protonmail.com
State New
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Commit Message

John Kehayias April 28, 2023, 5:49 a.m. UTC
* gnu/packages/python-xyz.scm (python-installer): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e2d082091f..83beb1c8ef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1329,6 +1329,24 @@  (define-public python-d2to1
 distribute/setuptools setup.py script.")
     (license license:bsd-2)))

+(define-public python-installer
+  (package
+    (name "python-installer")
+    (version "0.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "installer" version))
+              (sha256
+               (base32
+                "0cdnqh3a3amw8k4s1pzfjh0hpvzw4pczgl702s1b16r82qqkwvd2"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-flit-core python-pytest))
+    (home-page "https://installer.readthedocs.io/")
+    (synopsis "A library for installing Python wheels.")
+    (description
+     "This package provides a library for installing Python wheels.")
+    (license license:expat)))
+
 (define-public python-rawkit
   (package
     (name "python-rawkit")