diff mbox series

[bug#63139,python,10/20] gnu: python-virtualenv: Update to 20.22.0.

Message ID 1f7380517d02ae1221a3d3169775357e9828d082.1682660104.git.john.kehayias@protonmail.com
State New
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Commit Message

John Kehayias April 28, 2023, 5:50 a.m. UTC
* gnu/packages/python-xyz.scm (python-virtualenv): Update to 20.22.0.
[build-system]: Switch to pyproject-build-system.
[arguments]{test-flags}: Disable failing tests.
[native-inputs]: Remove python-mock and python-setuptools-scm.  Add
python-cython, python-flaky, python-hatch-vcs, python-hatchling, and
python-pytest-mock.
[propagated-inputs]: Remove python-appdirs and python-six.  Add
python-platformdirs.
---
 gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++++++++++++++-----
 1 file changed, 34 insertions(+), 5 deletions(-)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 62ed69c437..1f55df0cd9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4467,19 +4467,48 @@  (define-public python-vine
 (define-public python-virtualenv
   (package
     (name "python-virtualenv")
-    (version "20.3.1")
+    (version "20.22.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "virtualenv" version))
        (sha256
         (base32
-         "1nbhnpzswcf3lmzn5xabmfdd7ki8r2w2i37y6wml54di6qi1l48c"))))
-    (build-system python-build-system)
+         "1hvcc518l3byvk0hykb5x85fjh70w72s9f3d9vqs1wdfgb2571r7"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags
+           ;; TODO: Some of these tests may be able to be worked around.
+           ;; Currently they fail due to needing network access and/or trying
+           ;; to interact with the build environment in a way that does not
+           ;; work, or for unknown reasons.
+           '(let ((disabled-tests (list "test_acquire"
+                                        "test_activation_support"
+                                        "test_bootstrap_link_via_app_data"
+                                        "test_build_c_ext"
+                                        "test_builtin_discovery_class_preferred"
+                                        "test_can_symlink_when_symlinks_not_enabled"
+                                        "test_cpython3_win"
+                                        "test_creator"
+                                        "test_failed_to_find_implementation"
+                                        "test_periodic_update "
+                                        "test_pip_invoke"
+                                        "test_py_info"
+                                        "test_pypy3"
+                                        "test_value_alias"
+                                        "test_wheel_support_no_python_requires")))
+              (list "-k" (string-append "not "
+                                        (string-join disabled-tests
+                                                     " and not "))))))
     (native-inputs
-     (list python-mock python-pytest python-setuptools-scm))
+     (list python-cython
+           python-flaky
+           python-hatch-vcs
+           python-hatchling
+           python-pytest
+           python-pytest-mock))
     (propagated-inputs
-     (list python-appdirs python-distlib python-filelock python-six))
+     (list python-distlib python-filelock python-platformdirs))
     (home-page "https://virtualenv.pypa.io/")
     (synopsis "Virtual Python environment builder")
     (description