diff mbox series

[bug#63139,python,06/20] gnu: Add python-deepdiff.

Message ID d6f0788757a457d0e286a5f67c4ac6bde1d24a51.1682660104.git.john.kehayias@protonmail.com
State New
Headers show
Series Updates for pyproject-build-system, poetry, python-yubikey-manager | expand

Commit Message

John Kehayias April 28, 2023, 5:50 a.m. UTC
* gnu/packages/python-xyz.scm (python-deepdiff): New variable.
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e94f8067f3..95eea4ecf2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18072,6 +18072,33 @@  (define-public python-cachy
 database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
     (license license:expat)))

+(define-public python-deepdiff
+  (package
+    (name "python-deepdiff")
+    (version "6.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "deepdiff" version))
+              (sha256
+               (base32
+                "0i5nnb3nppi2vgbhiakpxiagyhx7l1f50hzcl8fcgica4bkz2fva"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-ordered-set))
+    (native-inputs (list python-dateutil
+                         python-click
+                         python-jsonpickle
+                         python-numpy
+                         python-pytest
+                         python-pyyaml))
+    (home-page "https://zepworks.com")
+    (synopsis
+     "Deep difference of any Python objects")
+    (description
+     "Deep Difference and Search of any Python object/data.  Recreate objects
+by adding adding deltas to each other.  Also includes DeepSearch for searching
+for objects within other objects and DeepHash to hash any object.")
+    (license license:expat)))
+
 (define-public poetry
   (package
     (name "poetry")