diff mbox series

[bug#56706,07/17] gnu: Add trytond-analytic-budget.

Message ID de98c9ab934daffac9c3988b041f0ccd5acda787.1658504594.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update Tryton to 6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 3:47 p.m. UTC
* gnu/packages/tryton.scm (trytond-analytic-budget): New variable.
---
 gnu/packages/tryton.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 2bc7388af4..548d34ded6 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1333,6 +1333,29 @@  required to analyse accounting using multiple different axes.")
   (deprecated-package
    "python-trytond-analytic-account" trytond-analytic-account))
 
+(define-public trytond-analytic-budget
+  (package
+    (name "trytond-analytic-budget")
+    (version "6.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "trytond_analytic_budget" version))
+              (sha256
+               (base32 "080a1s9w6n50xi2r7d3jkyk84rdqzggbqzhab9qjgppl67q85m8p"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_analytic_budget"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list trytond trytond-account-budget
+                             trytond-analytic-account
+                             trytond-company))
+    (home-page "https://docs.tryton.org/projects/modules-analytic-budget")
+    (synopsis "Allow creating budgets for analytic accounts in Tryton")
+    (description "The @emph{Analytic Budget} Tryton module provides the
+ability to set budgets for analytic accounts over a defined period of time.
+These budgets can then be used to track the total amount from relevant
+transactions against the budgeted amount.")
+    (license license:gpl3+)))
+
 (define-public trytond-analytic-invoice
   (package
     (name "trytond-analytic-invoice")