diff mbox series

[bug#56706,03/17] gnu: Add trytond-account-budget.

Message ID d38376183aaef5203217c171ea38a897546ff033.1658504594.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update Tryton to 6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 3:47 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-budget): New variable.
---
 gnu/packages/tryton.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 5307b0994d..6f23366e4c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -276,6 +276,28 @@  of fixed assets.")
 chart of account for Belgium.")
     (license license:gpl3+)))
 
+(define-public trytond-account-budget
+  (package
+    (name "trytond-account-budget")
+    (version "6.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "trytond_account_budget" version))
+              (sha256
+               (base32 "055y9jjpx4xfrc6dlssvjzmjz7rrvfljlaljx0v6c6s87mpzi3m5"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_account_budget"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list trytond trytond-account
+                             trytond-company trytond-currency))
+    (home-page "https://docs.tryton.org/projects/modules-account-budget")
+    (synopsis "Tryton module that allows budgets to be setup for accounts")
+    (description "The @emph{Account Budget} Tryton module provides the ability
+to set budgets for accounts over a defined period of time.  These budgets can
+then be used to track the total amount from relevant transactions against the
+budgeted amount.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-cash-rounding
   (package
     (name "trytond-account-cash-rounding")