diff mbox series

[bug#56706,16/17] gnu: Add python-shopifyapi.

Message ID 5dbd1e9bd7fc0537845f3b22d8576541554588cc.1658504594.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update Tryton to 6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 3:48 p.m. UTC
* gnu/packages/python-web.scm (python-shopifyapi): New variable.
---
 gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 07e6625964..ee722346b6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7638,3 +7638,26 @@  code- and protocol-based conventions that make it easy for Active Resource to
 infer complex relations and structures.")
     (license license:expat)))
 
+(define-public python-shopifyapi
+  (package
+    (name "python-shopifyapi")
+    (version "12.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "ShopifyAPI" version))
+              (sha256
+               (base32
+                "03np9mkycqbw5l5vk0srmq353q3vmbycbbarzv0cg3z703p81gnb"))))
+    (build-system python-build-system)
+    (native-inputs (list python-mock))
+    (propagated-inputs (list python-pyactiveresource python-pyjwt
+                             python-pyyaml python-six))
+    (home-page "https://github.com/Shopify/shopify_python_api")
+    (synopsis "Shopify API for Python")
+    (description "This package provides the Shopify API for Python.
+
+The ShopifyAPI library allows Python developers to programmatically access the
+admin section of stores using an ActiveResource-like interface similar the
+ruby Shopify API gem.  The library makes HTTP requests to Shopify in order to
+list, create, update, or delete resources (e.g. Order, Product, Collection).")
+    (license license:expat)))