diff mbox series

[bug#56706,08/17] gnu: Add trytond-currency-ro.

Message ID 73913fa301f7ca53ec6f63697addccd525c76b7b.1658504594.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update Tryton to 6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 3:47 p.m. UTC
* gnu/packages/tryton.scm (trytond-currency-ro): New variable.
---
 gnu/packages/tryton.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 548d34ded6..e906e4f719 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1762,6 +1762,26 @@  currency and rate.")
 (define-public python-trytond-currency
   (deprecated-package "python-trytond-currency" trytond-currency))
 
+(define-public trytond-currency-ro
+  (package
+    (name "trytond-currency-ro")
+    (version "6.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "trytond_currency_ro" version))
+              (sha256
+               (base32 "1kn4bgh1gg5dcphb2afqb922myyg2012vdhixipmi7ccbv7ik46s"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_currency_ro"))
+        (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list python-lxml python-requests trytond
+                             trytond-currency))
+    (home-page "https://docs.tryton.org/projects/modules-currency-ro")
+    (synopsis "Fetch currency rates from the Romanian National Bank")
+    (description "The @emph{Currency RO} Tryton module adds the Romanian
+National Bank as a source for currency exchange rates.")
+    (license license:gpl3+)))
+
 (define-public trytond-customs
   (package
     (name "trytond-customs")