diff mbox series

[bug#56706,09/17] gnu: Add trytond-currency-rs.

Message ID 55aa828e35ff1bdc7eb3d5a754a8245735714ef4.1658504594.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update Tryton to 6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 3:47 p.m. UTC
* gnu/packages/tryton.scm (trytond-currency-rs): New variable.
---
 gnu/packages/tryton.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index e906e4f719..ed82a7ebec 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1782,6 +1782,26 @@  currency and rate.")
 National Bank as a source for currency exchange rates.")
     (license license:gpl3+)))
 
+(define-public trytond-currency-rs
+  (package
+    (name "trytond-currency-rs")
+    (version "6.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "trytond_currency_rs" version))
+              (sha256
+               (base32 "05admscvj5m7anhji2ni9w2d8b33vlgcifda6jbrxdw8g4c0yivn"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_currency_rs"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list python-lxml trytond trytond-currency
+                             python-zeep))
+    (home-page "https://docs.tryton.org/projects/modules-currency-rs")
+    (synopsis "Fetch currency rates from the Serbian National Bank")
+    (description "The @emph{Currency RS} Tryton module adds the Serbian
+National Bank as a source for currency exchange rates.")
+    (license license:gpl3+)))
+
 (define-public trytond-customs
   (package
     (name "trytond-customs")