diff mbox series

[bug#65479,core-updates,v2,23/62] gnu: gtk-doc: Add libxslt native-search-paths to its own.

Message ID c7f2284bfe5a0bb30511dd59156d34d30920d5f8.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:19 p.m. UTC
Grepping through the built package, gtk-doc invokes 'xsltproc' so we propagate
the search paths in order for 'xsltproc' to find the XML/SGML catalog files.
Note that due to a module cycle we must duplicate it instead of using
'(package-native-search-paths libxslt)'.

* gnu/packages/gtk.scm (gtk-doc)[native-search-paths]: Add $SGML_CATALOG_FILES
and $XML_CATALOG_FILES.
---
 gnu/packages/gtk.scm | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0d6df1f583..082039fa6e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -60,6 +60,7 @@  (define-module (gnu packages gtk)
   #:use-module (guix download)
   #:use-module (guix bzr-download)
   #:use-module (guix git-download)
+  #:use-module (guix search-paths)
   #:use-module ((guix build utils) #:select (alist-replace))
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system glib-or-gtk)
@@ -2227,6 +2228,12 @@  (define-public gtk-doc
            python-pygments
            source-highlight
            yelp-tools))
+    (native-search-paths
+     ;; xsltproc's search paths, to avoid propagating libxslt.
+     ;; XXX: There's a module cycle as (gnu packages xml) imports
+     ;; (gnu packages gtk) so we can't use (package-native-search-paths …)
+     ;; and must duplicate it here instead.
+     (list $SGML_CATALOG_FILES $XML_CATALOG_FILES))
     (home-page "https://wiki.gnome.org/DocumentationProject/GtkDoc")
     (synopsis "GTK+ DocBook Documentation Generator")
     (description "GtkDoc is a tool used to extract API documentation from C-code