diff mbox series

[bug#65479,core-updates,v2,03/62] gnu: docbook-xml-5.1: Fix URIs in catalog.xml.

Message ID 52bffd0b261be7dd2452c72d0cb498446b677ae0.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:19 p.m. UTC
* gnu/packages/docbook.scm (docbook-xml-5.1)[source]: Patch version in URI.
---
 gnu/packages/docbook.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer Oct. 5, 2023, 7:23 p.m. UTC | #1
Hi,

Bruno Victal <mirai@makinata.eu> writes:

> * gnu/packages/docbook.scm (docbook-xml-5.1)[source]: Patch version in URI.
> ---
>  gnu/packages/docbook.scm | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
> index ec1b9acb36..4a0104c253 100644
> --- a/gnu/packages/docbook.scm
> +++ b/gnu/packages/docbook.scm
> @@ -109,7 +109,13 @@ (define-public docbook-xml-5.1
>                                         "/docbook-v" version "-os.zip"))
>                     (sha256
>                      (base32
> -                     "0zqy9prj9wam9dn7v3mgr7ld1axqxdhgrmv06dviwg00ahv43wxk"))))
> +                     "0zqy9prj9wam9dn7v3mgr7ld1axqxdhgrmv06dviwg00ahv43wxk"))
> +                   (modules '((guix build utils)))
> +                   (snippet
> +                    ;; The .zip release mistakenly uses '5.1CR4' instead of
> +                    ;; '5.1' as intended by <https://docbook.org/xml/5.1/catalog.xml>.
> +                    #~(substitute* "schemas/catalog.xml"
> +                        (("5\\.1CR4") #$version)))))

Fun!  Is this known upstream?
Bruno Victal Oct. 6, 2023, 3:23 p.m. UTC | #2
On 2023-10-05 20:23, Maxim Cournoyer wrote:
>> +                    ;; The .zip release mistakenly uses '5.1CR4' instead of
>> +                    ;; '5.1' as intended by <https://docbook.org/xml/5.1/catalog.xml>.
>> +                    #~(substitute* "schemas/catalog.xml"
>> +                        (("5\\.1CR4") #$version)))))
> 
> Fun!  Is this known upstream?

No idea. (it doesn't look obvious where issues should be reported to)
The upstream is rather strange IMO: the .zip releases don't seem
to get updated (otherwise we'd see docbook-xml-4.1.2 retrofitted with
a catalog.xml instead of leaving it up to distros to figure this one
out in painful ways) and the files in the .zip don't match against
the files in their HTTP mirror [1].

You can see that [2] doesn't have the bogus entries that are in the
zip release [3].

My guess is that the HTTP mirror gets “hotfixes” but the .zip release
is the original release that is left frozen in time.

Other fun extras:
There seems to be a OASIS “upstream” as well [5][6], and the URIs in
the catalog [7] for the same standard are different!!

Not only that, the OASIS “upstream” lists a 5.1.1 release [8] which
is absent from the official [4] home page.


[1]: <https://docbook.org/xml/5.1/>
[2]: <https://docbook.org/xml/5.1/catalog.xml>
[3]: <https://docbook.org/xml/5.1/docbook-v5.1-os.zip>
[4]: <https://docbook.org/schemas/5x>
[5]: <https://docs.oasis-open.org/docbook/docbook/>
[6]: <https://www.oasis-open.org/committees/tc_home.php?wg_abbrev=docbook>
[7]: <https://docs.oasis-open.org/docbook/docbook/v5.1/cs01/schemas/catalog.xml>
[8]: <https://docs.oasis-open.org/docbook/docbook/v5.1.1/>
Maxim Cournoyer Oct. 7, 2023, 5:04 p.m. UTC | #3
Hello!

Bruno Victal <mirai@makinata.eu> writes:

> On 2023-10-05 20:23, Maxim Cournoyer wrote:
>>> +                    ;; The .zip release mistakenly uses '5.1CR4' instead of
>>> +                    ;; '5.1' as intended by <https://docbook.org/xml/5.1/catalog.xml>.
>>> +                    #~(substitute* "schemas/catalog.xml"
>>> +                        (("5\\.1CR4") #$version)))))
>> 
>> Fun!  Is this known upstream?
>
> No idea. (it doesn't look obvious where issues should be reported to)

They appear to accept issues on their Github:
https://github.com/docbook/docbook/issues

> The upstream is rather strange IMO: the .zip releases don't seem
> to get updated (otherwise we'd see docbook-xml-4.1.2 retrofitted with
> a catalog.xml instead of leaving it up to distros to figure this one
> out in painful ways) and the files in the .zip don't match against
> the files in their HTTP mirror [1].
>
> You can see that [2] doesn't have the bogus entries that are in the
> zip release [3].
>
> My guess is that the HTTP mirror gets “hotfixes” but the .zip release
> is the original release that is left frozen in time.
>
> Other fun extras:
> There seems to be a OASIS “upstream” as well [5][6], and the URIs in
> the catalog [7] for the same standard are different!!
>
> Not only that, the OASIS “upstream” lists a 5.1.1 release [8] which
> is absent from the official [4] home page.

Interesting.  If you could forward all these oddities to an issue
upstream perhaps that'd help them or someone else.
Bruno Victal Oct. 7, 2023, 5:14 p.m. UTC | #4
On 2023-10-07 18:04, Maxim Cournoyer wrote:
> They appear to accept issues on their Github:
> https://github.com/docbook/docbook/issues

Indeed, I see that this 5.1CR4 issue has already been reported
upstream [1] and fixed in [2] but it seems the zip archive remained
unchanged.

Searching for catalog related issues has yielded [3] which we might
need to account for as well. I'll try to address these in the upcoming
revision.


[1]: <https://github.com/docbook/docbook/issues/100>
[2]: <https://docbook.org/xml/5.1/catalog.xml>
[3]: <https://github.com/docbook/docbook/issues/201>
diff mbox series

Patch

diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index ec1b9acb36..4a0104c253 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -109,7 +109,13 @@  (define-public docbook-xml-5.1
                                        "/docbook-v" version "-os.zip"))
                    (sha256
                     (base32
-                     "0zqy9prj9wam9dn7v3mgr7ld1axqxdhgrmv06dviwg00ahv43wxk"))))
+                     "0zqy9prj9wam9dn7v3mgr7ld1axqxdhgrmv06dviwg00ahv43wxk"))
+                   (modules '((guix build utils)))
+                   (snippet
+                    ;; The .zip release mistakenly uses '5.1CR4' instead of
+                    ;; '5.1' as intended by <https://docbook.org/xml/5.1/catalog.xml>.
+                    #~(substitute* "schemas/catalog.xml"
+                        (("5\\.1CR4") #$version)))))
          (template (docbook-xml-package source version)))
     (package
       (inherit template)