diff mbox series

[bug#65479,core-updates,v2,13/62] gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.

Message ID 6fae21fb2011c2598abbdcea7611efd54bc45cfb.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:19 p.m. UTC
According to the xmllint manpage it also makes use of the SGML_CATALOG_FILES
environment variable.

* gnu/packages/xml.scm (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.

Co-authored-by: gemmaro <gemmaro.dev@gmail.com>
---
 gnu/packages/xml.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 75a14d0824..6aa5a22e67 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -226,7 +226,8 @@  (define-public libxml2
     (inputs (list xz))
     (propagated-inputs (list zlib)) ; libxml2.la says '-lz'.
     (native-inputs (list perl))
-    (native-search-paths (list $XML_CATALOG_FILES))
+    (native-search-paths
+     (list $SGML_CATALOG_FILES $XML_CATALOG_FILES))
     (search-paths native-search-paths)
     (description
      "Libxml2 is the XML C parser and toolkit developed for the Gnome