diff mbox series

[bug#65479,core-updates,v2,14/62] gnu: libxslt: Set search-paths for XML and SGML catalogs.

Message ID 81881efffa61672124d5f79b9a19ca9145f0d5a0.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:19 p.m. UTC
According to xsltproc manpage it supports both XML_CATALOG_FILES and
SGML_CATALOG_FILES for catalog lookup.

* gnu/packages/xml.scm (libxslt)[native-search-paths]: Add SGML_CATALOG_FILES
and XML_CATALOG_FILES.
[search-paths]: Likewise.
* gnu/packages/perl.scm (perl-app-xml-docbook-builder)[native-search-paths]:
Refer to libxslt native-search-paths.
---
 gnu/packages/perl.scm | 2 +-
 gnu/packages/xml.scm  | 3 +++
 2 files changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 267a35e560..3ed0668fa3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -601,7 +601,7 @@  (define-public perl-app-xml-docbook-builder
      (list perl-class-xsaccessor perl-test-trap))
     (native-search-paths
      ;; xsltproc's search paths, to avoid propagating libxslt.
-     (list $XML_CATALOG_FILES))
+     (package-native-search-paths libxslt))
     (home-page "https://www.shlomifish.org/open-source/projects/docmake/")
     (synopsis "Translate DocBook/XML documentation into other file formats")
     (description
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 6aa5a22e67..ab4001e885 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -365,6 +365,9 @@  (define-public libxslt
            xz))
     (native-inputs
      (list pkg-config))
+    (native-search-paths
+     (list $SGML_CATALOG_FILES $XML_CATALOG_FILES))
+    (search-paths native-search-paths)
     (description
      "Libxslt is an XSLT C library developed for the GNOME project.  It is
 based on libxml for XML parsing, tree manipulation and XPath support.")