diff mbox series

[bug#65479,core-updates,v2,21/62] gnu: xmlto: Rewrite with G-Expressions.

Message ID b527e43b6801c4bddae8a3b890738156574bff6c.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:19 p.m. UTC
* gnu/packages/xml.scm (xmlto)[arguments]: Rewrite with G-Expressions.
---
 gnu/packages/xml.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ab4001e885..447bdcf117 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1125,10 +1125,11 @@  (define-public xmlto
     (build-system gnu-build-system)
     (arguments
      ;; Make sure the reference to util-linux's 'getopt' is kept in 'xmlto'.
-     '(#:configure-flags (list (string-append "GETOPT="
-                                              (assoc-ref %build-inputs
-                                                         "util-linux")
-                                              "/bin/getopt"))))
+     (list
+      #:configure-flags
+      #~(list (string-append "GETOPT="
+                             #$(this-package-input "util-linux")
+                             "/bin/getopt"))))
     (native-inputs
      (list util-linux))
     (inputs