diff mbox series

[bug#65479,core-updates,v2,33/62] gnu: git-crypt: Remove docbook workarounds.

Message ID bcd3b648c2bc80be61e37957397d7dc6de598b6e.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:20 p.m. UTC
* gnu/packages/version-control.scm (git-crypt)[arguments]: Use G-Expressions.
<#:phases>: Refactored into …
<#:make-flags>: … here.
[native-inputs]: Add docbook-xml-4.2.
---
 gnu/packages/version-control.scm | 41 +++++++++++---------------------
 1 file changed, 14 insertions(+), 27 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 86dcea908c..9f9392fad1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -48,6 +48,7 @@ 
 ;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;; Copyright © 2015, 2022 David Thompson <davet@gnu.org>
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -942,34 +943,20 @@  (define-public git-crypt
     (inputs
      (list git openssl))
     (native-inputs
-     (list docbook-xsl libxslt))
+     (list docbook-xml-4.2 docbook-xsl libxslt))
     (arguments
-     `(#:tests? #f ; No tests.
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (add-after 'unpack 'patch-makefile
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "Makefile"
-               (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
-                (string-append (assoc-ref inputs "docbook-xsl")
-                               "/xml/xsl/docbook-xsl-"
-                               ,(package-version docbook-xsl)
-                               "/manpages/docbook.xsl")))
-             #t))
-         (replace 'build
-           (lambda _
-             ;; Add flag to work around OpenSSL 3 incompatibility.
-             ;; See <https://github.com/AGWA/git-crypt/issues/232>.
-             (setenv "CXXFLAGS" "-DOPENSSL_API_COMPAT=0x30000000L")
-
-             (invoke "make" "ENABLE_MAN=yes")))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (invoke "make" "install"
-                       "ENABLE_MAN=yes"
-                       (string-append "PREFIX=" out))))))))
+     (list
+      #:tests? #f ; No tests.
+      #:make-flags
+      #~(list
+         "ENABLE_MAN=yes"
+         ;; Add flag to work around OpenSSL 3 incompatibility.
+         ;; See <https://github.com/AGWA/git-crypt/issues/232>.
+         "CXXFLAGS+=-DOPENSSL_API_COMPAT=0x30000000L"
+         (string-append "PREFIX=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))))
     (home-page "https://www.agwa.name/projects/git-crypt/")
     (synopsis "Transparent encryption of files in a git repository")
     (description "git-crypt enables transparent encryption and decryption of