diff mbox series

[bug#65479,core-updates,v2,62/62] gnu: Remove docbook-xsl-1.79.1.

Message ID ad97561dc011e42bfc77dfa4763cbfb3782968dc.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:20 p.m. UTC
* gnu/packages/docbook.scm (docbook-xsl-1.79.1): Remove variable.
* gnu/packages/gnome.scm (colord)[native-inputs]: Replace with docbook-xsl.
---
 gnu/packages/docbook.scm | 86 ----------------------------------------
 gnu/packages/gnome.scm   |  2 +-
 2 files changed, 1 insertion(+), 87 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index e3de6bc00a..8edd30d063 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -502,92 +502,6 @@  (define-public docbook-xsl
        "This package provides XSL style sheets for DocBook.")
       (license (license:x11-style "" "See 'COPYING' file.")))))
 
-(define-public docbook-xsl-1.79.1
-  (package
-    (name "docbook-xsl")
-    (version "1.79.1")
-    (source (origin
-              (method url-fetch)
-              ;; At the time, the non namespaced version was still the
-              ;; default; our latest docbook-xsl is namespaced, so for
-              ;; consistency preserves this property for older versions too.
-              (uri (string-append "mirror://sourceforge/docbook/"
-                                  name "-ns/" version "/"
-                                  name "-ns-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "170ggf5dgjar65kkn5n33kvjr3pdinpj66nnxfx8b2avw0k91jin"))
-              (modules '((guix build utils)))
-              ;; Bundled binary files.
-              (snippet
-               #~(delete-file-recursively "tools"))))
-    (build-system copy-build-system)
-    (outputs '("out" "doc"))
-    (arguments
-     (list
-      #:install-plan
-      (let ((target (format #f "xml/xsl/~a-~a/" name version))
-            (select-rx '("\\.xml$" "\\.xsl$" "\\.dtd$" "\\.ent$")))
-        #~`(#$@(map
-                (lambda (directory)
-                  ;; XXX: When filters are used, the source basename
-                  ;; isn't kept under the target path, append it again.
-                  (let ((target* (string-append target directory)))
-                    (list directory target* #:include-regexp select-rx)))
-                (list "assembly" "common" "eclipse" "epub" "epub3" "fo"
-                      "highlighting" "html" "htmlhelp" "javahelp" "lib"
-                      "manpages" "params" "profiling" "roundtrip"
-                      "template" "website"
-                      "xhtml" "xhtml-1_1" "xhtml5"))
-            ("catalog.xml" #$target)
-            ("VERSION.xsl" #$target)))
-      #:phases
-      #~(let ((dest-path (format #f "~a/xml/xsl/~a-~a"
-                                 #$output #$name #$version)))
-          (modify-phases %standard-phases
-            (add-before 'install 'patch-catalog-xml
-              (lambda* (#:key inputs #:allow-other-keys)
-                (let ((xmlcatalog (search-input-file inputs
-                                                     "/bin/xmlcatalog"))
-                      (catalog-files (find-files "." "catalog\\.xml$"))
-                      (store-uri (string-append "file://" dest-path "/")))
-                  (for-each
-                   (lambda (catalog)
-                     (for-each
-                      (lambda (type)
-                        ;; Patch /current/ references to point to /gnu/store/….
-                        (invoke xmlcatalog "--noout"
-                                "--add" type
-                                "http://docbook.sourceforge.net/release/xsl-ns/current/"
-                                store-uri
-                                catalog)
-                        ;; Patch versioned references to point to /gnu/store/….
-                        (invoke xmlcatalog "--noout"
-                                "--add" type
-                                (format
-                                 #f "http://docbook.sourceforge.net/release/xsl-ns/~a/"
-                                 #$version)
-                                store-uri
-                                catalog))
-                      (list "rewriteSystem" "rewriteURI")))
-                   catalog-files))))
-            ;; XXX: The copy-build-system doesn't seem to allow installing to a
-            ;; different output.
-            (add-after 'install 'install-doc
-              (lambda _
-                (let ((doc (format #f "~a/share/doc/~a-~a"
-                                   #$output:doc #$name #$version)))
-                  (install-file "NEWS" doc)
-                  (install-file "RELEASE-NOTES.html" doc)
-                  (copy-recursively "slides" doc)
-                  (copy-recursively "webhelp" doc))))))))
-    (native-inputs (list libxml2))
-    (home-page "https://docbook.org")
-    (synopsis "DocBook XSL namespaced style sheets for document authoring")
-    (description "This package provides the @emph{namespaced} XSL style sheets
-for DocBook.")
-    (license (license:x11-style "" "See 'COPYING' file."))))
-
 (define-public docbook-dsssl
   (package
     (name "docbook-dsssl")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index aeb5544fe0..06495a48f8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5631,7 +5631,7 @@  (define-public colord
     (native-inputs
      (modify-inputs (package-native-inputs colord-minimal)
        (append bash-completion
-               docbook-xsl-1.79.1
+               docbook-xsl
                gtk-doc/stable
                libxslt
                sane-backends