diff mbox series

[bug#65479,core-updates,v2,52/62] gnu: git: Drop docbook workarounds.

Message ID 2c3b9a753e2696e00dff8b7e2e44afb95010d769.1695478390.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements. | expand

Commit Message

Bruno Victal Sept. 23, 2023, 2:20 p.m. UTC
* gnu/packages/version-control.scm (git)[arguments]<#:phases>: Drop
docbook-xsl related substitution.
[native-inputs]: Add docbook-xml-4.5.
---
 gnu/packages/version-control.scm | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9f9392fad1..9e6b9cd1ac 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -262,6 +262,7 @@  (define-public git
       ;; For subtree documentation.
       ("asciidoc" ,asciidoc)
       ("docbook2x" ,docbook2x)
+      ("docbook-xml" ,docbook-xml-4.5)
       ("docbook-xsl" ,docbook-xsl)
       ("libxslt" ,libxslt)
       ("pkg-config" ,pkg-config)
@@ -382,17 +383,6 @@  (define-public git
          (add-after 'build 'build-subtree
            (lambda* (#:key inputs #:allow-other-keys)
              (with-directory-excursion "contrib/subtree"
-               (substitute* "Makefile"
-                 ;; Apparently `xmlto' does not bother to looks up the stylesheets
-                 ;; specified in the XML, unlike the above substitution.  Instead it
-                 ;; uses a hard-coded URL.  Work around it here, but if this is
-                 ;; common perhaps we should hardcode this path in xmlto itself.
-                 (("\\$\\(XMLTO\\) -m \\$\\(MANPAGE_XSL\\)")
-                  (string-append "$(XMLTO) -x "
-                                 (string-append (assoc-ref inputs "docbook-xsl")
-                                                "/xml/xsl/docbook-xsl-"
-                                                ,(package-version docbook-xsl))
-                                 "/manpages/docbook.xsl -m $(MANPAGE_XSL)")))
                (invoke "make")
                (invoke "make" "install")
                (invoke "make" "install-doc")