diff mbox series

[bug#70735,061/714] gnu: python-pure-protobuf: Remove python-flake8 native-input.

Message ID 20240503224254.28001-61-ngraves@ngraves.fr
State New
Headers show
Series [bug#70735,001/714] gnu: python-transient: Remove python-black native-input. | expand

Commit Message

Nicolas Graves May 3, 2024, 10:19 p.m. UTC
* gnu/packages/protobuf.scm (python-pure-protobuf):
  [arguments]<#:phases>: Remove flake8 invocation from check phase.
  [native-inputs]: Remove python-flake8.

Change-Id: I732aee31aff6e52984aeff0d4be6eafbae2d7a5c
---
 gnu/packages/protobuf.scm | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 8ca730df3c..502ad09a3a 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -469,7 +469,7 @@  (define-public python-pure-protobuf
         (base32 "15dp5pvazd0jx4wzzh79080ah7hkpd3axh40al9vhzs2hf3v90hx"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-flake8 python-pytest python-pytest-cov python-isort))
+     (list python-pytest python-pytest-cov python-isort))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -477,8 +477,6 @@  (define-public python-pure-protobuf
            (lambda _
              (invoke "pytest" "--cov-report" "term-missing" "--cov"
                      "pure_protobuf")
-             (invoke "flake8" "pure_protobuf" "tests"
-                     "--ignore=F541")
              (invoke "isort" "-rc" "-c" "pure_protobuf" "tests"))))))
     (home-page "https://pypi.org/project/pure-protobuf/")
     (synopsis "Protobuf implementation using dataclasses")