diff mbox series

[bug#70735,015/714] gnu: python-isort: Improve package style.

Message ID 20240503224254.28001-15-ngraves@ngraves.fr
State New
Headers show
Series [bug#70735,001/714] gnu: python-transient: Remove python-black native-input. | expand

Commit Message

Nicolas Graves May 3, 2024, 10:18 p.m. UTC
* gnu/packages/python-xyz.scm (python-isort): Improve package style.
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:test-flags>: Add option to replace former check phase.
  <#:phases>: Remove phases build, install and check.

Change-Id: Idac8f151977f2494eb44d51aa1fcbf3156b5cc87
---
 gnu/packages/python-xyz.scm | 22 ++++------------------
 1 file changed, 4 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c81cd2d51..8be0040220 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23654,19 +23654,13 @@  (define-public python-isort
        (sha256
         (base32
          "1vbwc4gpffclf6hw08lvvgqlvsgfjlw7gjsm28jfcrln2pixla7j"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags '(list "tests/unit/" "-k" "not test_gitignore"
+                          "--ignore=tests/unit/test_deprecated_finders.py")
       #:phases
       #~(modify-phases %standard-phases
-          (replace 'build
-            (lambda _
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl))))
           (add-after 'install 'install-example-plugins
             (lambda _
               (for-each (lambda (source-directory)
@@ -23680,15 +23674,7 @@  (define-public python-isort
               (setenv "HOME" (getcwd))
               (let ((example-whls (find-files "dist" "^example.*\\.whl$")))
                 (apply invoke "pip" "--no-cache-dir" "--no-input"
-                       "install"  "--user" "--no-deps" example-whls))))
-          (replace 'check
-            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-              (when tests?
-                (let ((bin (string-append #$output "/bin")))
-                  (setenv "PATH" (string-append (getenv "PATH") ":" bin)))
-                (invoke "pytest" "-vv" "tests/unit/"
-                        "-k" "not test_gitignore" ;requires git
-                        "--ignore=tests/unit/test_deprecated_finders.py")))))))
+                       "install"  "--user" "--no-deps" example-whls)))))))
     (native-inputs
      (list python-black
            python-colorama