diff mbox series

[bug#70739,075/714] gnu: python-versioneer: Remove python-flake8 native-input.

Message ID 20240503172650.32434-75-ngraves@ngraves.fr
State New
Headers show
Series python native-inputs | expand

Commit Message

Nicolas Graves May 3, 2024, 4:56 p.m. UTC
* gnu/packages/python-xyz.scm (python-versioneer):
  [arguments]<#:phases>: Remove flake8 invocation during check phase.
  [native-inputs]: Remove python-flake8.

Change-Id: Ied4ee355674413f99f4625b499d9418bdaf3e9e1
---
 gnu/packages/python-xyz.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2594345f83..11407c3720 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31962,11 +31962,10 @@  (define-public python-versioneer
                 (invoke "pyflakes" "setup.py" "versioneer.py" "git_version.py")
                 (invoke "python" "test/run_pyflakes_src.py")
                 (invoke "pyflakes" "test")
-                (invoke "flake8" "git_version.py" "versioneer.py")
                 (invoke "pycodestyle" "--max-line-length=88"
                         "git_version.py" "versioneer.py")))))))
     (native-inputs
-     (list git-minimal python-flake8 python-pycodestyle python-pyflakes
+     (list git-minimal python-pycodestyle python-pyflakes
            python-pypa-build python-setuptools python-wheel))
     (propagated-inputs
      (list python-tomli))