diff mbox series

[bug#70739,060/714] gnu: python-mutagen: Remove python-flake8 native-input.

Message ID 20240503172650.32434-60-ngraves@ngraves.fr
State New
Headers show
Series python native-inputs | expand

Commit Message

Nicolas Graves May 3, 2024, 4:55 p.m. UTC
* gnu/packages/music.scm (python-mutagen):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:test-flags>: Ignore flake8 quality tests.
  [native-inputs]: Remove python-flake8.

Change-Id: Ie7d2b26d6f4d9cdfdb022ea6d159c91325134320
---
 gnu/packages/music.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a8901d24a6..e2d0cee7b5 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3938,9 +3938,10 @@  (define-public python-mutagen
               (sha256
                (base32
                 "1qdk6i8gyhbi1c4j5jmbfpac3q8sff2ysri1pnp7nb9wzcp615v3"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags '(list "--ignore=tests/quality/test_flake8.py")
        #:phases
        #~(modify-phases %standard-phases
            (add-before 'check 'remove-hypothesis-deadlines
@@ -3951,7 +3952,7 @@  (define-public python-mutagen
                  (("( +)@given" all spaces)
                   (string-append spaces "@settings(deadline=None)\n" all))))))))
     (native-inputs
-     (list python-pytest python-hypothesis python-flake8))
+     (list python-pytest python-hypothesis))
     (home-page "https://mutagen.readthedocs.io/")
     (synopsis "Read and write audio tags")
     (description "Mutagen is a Python module to handle audio metadata.  It