diff mbox series

[bug#68941,v2,08/44] gnu: Add node-is-callable.

Message ID 20240208002527.27165-8-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-is-callable): New variable.
---
 gnu/packages/node-xyz.scm | 45 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 5d0b5a3e80..367360cd24 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -662,6 +662,51 @@  (define-public node-irc
 It has functions for joining, parting, talking, and many other IRC commands.")
     (license license:gpl3+)))
 
+(define-public node-is-callable
+  (package
+    (name "node-is-callable")
+    (version "1.2.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/inspect-js/is-callable")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0syzhiw9k1ync27avrpbz5vznz2yj2n4i2z4ypylv53flzar9hk6"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+		"aud"
+		"auto-changelog"
+		"available-typed-arrays"
+		"eclint"
+		"es-value-fixtures"
+		"eslint"
+		"for-each"
+		"has-tostringtag"
+		"make-arrow-function"
+		"make-async-function"
+		"make-generator-function"
+		"npmignore"
+		"nyc"
+		"object-inspect"
+		"rimraf"
+		"safe-publish-latest"
+                "tape")))))
+       #:tests? #f))  ; FIXME tests depend on node-tape.
+    (home-page "https://github.com/inspect-js/is-callable")
+    (synopsis "Javascript predicate to identify if value is callable")
+    (description "This package provides a Javascript function to identify if a
+value is callable.")
+    (license license:expat)))
+
 (define-public node-long-stack-traces
   (package
     (name "node-long-stack-traces")