diff mbox series

[bug#68941,v2,15/44] gnu: Add node-object-inspect.

Message ID 20240208002527.27165-15-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-object-inspect): New variable.
---
 gnu/packages/node-xyz.scm | 47 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 17b9b01cbf..8b2e0310a7 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1081,6 +1081,53 @@  (define-public node-normalize-path
 slashes, unless disabled.")
     (license license:expat)))
 
+(define-public node-object-inspect
+  (package
+    (name "node-object-inspect")
+    (version "1.12.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/inspect-js/object-inspect")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "16bki8gvgglxldj2gw38wlyihzkbjsf6wyxaids79x9215dl07iq"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+                "@pkgjs/support"
+                "aud"
+                "auto-changelog"
+                "core-js"
+                "error-cause"
+                "es-value-fixtures"
+                "eslint"
+                "for-each"
+                "functions-have-names"
+                "has-tostringtag"
+                "in-publish"
+                "jackspeak"
+                "make-arrow-function"
+                "mock-property"
+                "npmignore"
+                "nyc"
+                "safe-publish-latest"
+                "string.prototype.repeat"
+                "tape")))))
+       #:tests? #f))  ; FIXME tests depend on node-tape.
+    (home-page "https://github.com/inspect-js/object-inspect")
+    (synopsis "String representation of objects in Javascript")
+    (description "This package provides a Javascript function to inspect
+string representations of objects in Javascript.")
+    (license license:expat)))
+
 (define-public node-once
   (package
     (name "node-once")