diff mbox series

[bug#68941,v2,10/44] gnu: Add node-is-symbol.

Message ID 20240208002527.27165-10-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-is-symbol): New variable.
---
 gnu/packages/node-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 4df1525285..34bdc83d0a 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -755,6 +755,45 @@  (define-public node-is-callable
 value is callable.")
     (license license:expat)))
 
+(define-public node-is-symbol
+  (package
+    (name "node-is-symbol")
+    (version "1.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/inspect-js/is-symbol")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0lx6ym8y7wq3r1mzg6gbnpkd2dmprmylj14v1r6dj3sb8430kwps"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+		"aud"
+		"auto-changelog"
+		"eslint"
+		"has-tostringtag"
+		"in-publish"
+		"npmignore"
+		"nyc"
+		"object-inspect"
+		"safe-publish-latest"
+                "tape")))))
+       #:tests? #f))  ; FIXME tests depend on node-tape.
+    (inputs (list node-has-symbols))
+    (home-page "https://github.com/inspect-js/is-symbol")
+    (synopsis "Javascript predicate to identify if value is a symbol")
+    (description "This package provides a Javascript function to identify if a
+value is a @code{Symbol}.")
+    (license license:expat)))
+
 (define-public node-long-stack-traces
   (package
     (name "node-long-stack-traces")