diff mbox series

[bug#68941,v2,17/44] gnu: Add node-which-typed-array.

Message ID 20240208002527.27165-17-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-which-typed-array): New variable.
---
 gnu/packages/node-xyz.scm | 42 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 6575b81be0..232b99755f 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -2073,6 +2073,48 @@  (define-public node-util-deprecate
 function with browser support.")
     (license license:expat)))
 
+(define-public node-which-typed-array
+  (package
+    (name "node-which-typed-array")
+    (version "1.1.11")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/inspect-js/which-typed-array")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qrhihl9803hssw5ivivi29c9cvsq7mx4g9f0l2g1qij9vv9k5hy"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+                "aud"
+		"auto-changelog"
+		"eslint"
+		"in-publish"
+		"is-callable"
+		"make-arrow-function"
+		"make-generator-function"
+		"npmignore"
+		"nyc"
+		"safe-publish-latest"
+                "tape")))))
+       #:tests? #f))  ; FIXME tests depend on node-tape.
+    (inputs
+     (list node-available-typed-arrays node-call-bind node-for-each
+           node-has-tostringtag node-gopd))
+    (home-page "https://github.com/inspect-js/which-typed-array")
+    (synopsis "Javascript symbol support predicate function")
+    (description "This package provides a Javascript function to get and
+robustly cache all language-level intrinsics at first require time.")
+    (license license:expat)))
+
 (define-public node-wrappy
   (package
     (name "node-wrappy")