diff mbox series

[bug#68941,v2,03/44] gnu: Add node-function-bind.

Message ID 20240208002527.27165-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-function-bind): New variable.
---
 gnu/packages/node-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 36fa575049..a8607bd8b4 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -459,6 +459,38 @@  (define-public node-file-uri-to-path
 suitable for use with the @code{fs} module functions.")
     (license license:expat)))
 
+(define-public node-function-bind
+  (package
+    (name "node-function-bind")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Raynos/function-bind")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "19dcz6b3xs4hfxmjzr6b52r0rj3yziw8spzq4xpwnmggwyks7nm6"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+                "covert"
+                "eslint"
+                "jscs"
+                "tape")))))
+       #:tests? #f))
+    (home-page "https://github.com/Raynos/function-bind")
+    (synopsis "Implementation of function.prototype.bind")
+    (description "This package provides a robust implementation of the
+Function.prototype.bind Javascript function.")
+    (license license:expat)))
+
 (define-public node-global-gradle-clean
   (package
     (name "node-global-gradle-clean")