diff mbox series

[bug#68941,v2,12/44] gnu: Add node-available-typed-arrays.

Message ID 20240208002527.27165-12-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-available-typed-arrays): New variable.
---
 gnu/packages/node-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index fbd3cdcd67..ce496caf32 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -193,6 +193,44 @@  (define new-test-script
 ABI-stable across Node.js major versions.")
     (license license:expat)))
 
+(define-public node-available-typed-arrays
+  (package
+    (name "node-available-typed-arrays")
+    (version "1.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/inspect-js/available-typed-arrays")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qvs30h8q785ma719232ckzpfqn10f36mxqfxs8c8ipzbwyxjxm6"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+                "array.prototype.every"
+                "aud"
+                "auto-changelog"
+		"eslint"
+                "evalmd"
+                "isarray"
+		"nyc"
+		"safe-publish-latest"
+                "tape")))))
+       #:tests? #f))  ; FIXME tests depend on node-tape.
+    (home-page "https://github.com/inspect-js/available-typed-arrays")
+    (synopsis "Returns Typed Array names in the current environment")
+    (description
+   "This package provides a Javascript function to return an array of Typed
+Array names that are available in the current environment.")
+    (license license:expat)))
+
 (define-public node-bindings
   (package
     (name "node-bindings")