diff mbox series

[bug#68941,v2,24/44] gnu: Add node-is-array-buffer.

Message ID 20240208002527.27165-24-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-is-array-buffer): New variable.
---
 gnu/packages/node-xyz.scm | 42 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 9cd9311e07..3afca70451 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -864,6 +864,48 @@  (define-public node-irc
 It has functions for joining, parting, talking, and many other IRC commands.")
     (license license:gpl3+)))
 
+(define-public node-is-array-buffer
+  (package
+    (name "node-is-array-buffer")
+    (version "3.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/inspect-js/is-array-buffer")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1f8pa8vgdizfmmv929zjywn9kac7h5aqv6fvvfhq6f0my6p3zwm1"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+		"aud"
+		"auto-changelog"
+		"available-typed-arrays"
+		"es-value-fixtures"
+		"eslint"
+		"for-each"
+		"in-publish"
+		"npmignore"
+		"nyc"
+		"object-inspect"
+		"safe-publish-latest"
+                "tape")))))
+       #:tests? #f))  ; FIXME tests depend on node-tape.
+    (inputs
+     (list node-call-bind node-get-intrinsic node-is-typed-array))
+    (home-page "https://github.com/inspect-js/is-array-buffer")
+    (synopsis "Javascript predicate to identify @code{ArrayBuffer}")
+    (description "This package provides a function to identify if a value is
+Javascript @code{ArrayBuffer}.")
+    (license license:expat)))
+
 (define-public node-is-callable
   (package
     (name "node-is-callable")