diff mbox series

[bug#68941,v2,14/44] gnu: Add node-call-bind.

Message ID 20240208002527.27165-14-ngraves@ngraves.fr
State New
Headers show
Series [bug#68941,v2,01/44] guix: build-system: node: Add trivial-node-package helper. | expand

Commit Message

Nicolas Graves Feb. 8, 2024, 12:24 a.m. UTC
* gnu/packages/node-xyz.scm (node-call-bind): New variable.
---
 gnu/packages/node-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index abfebfbae4..17b9b01cbf 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -283,6 +283,42 @@  (define-public node-buffer-crc32
 and fancy character sets, signed or unsigned data and has tests, for Node.")
     (license license:expat)))
 
+(define-public node-call-bind
+  (package
+    (name "node-call-bind")
+    (version "1.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ljharb/call-bind")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1gqv3bisi64jzfgacwsx1rbd60bkadvpbsv66xgcn6r518qjdjix"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies
+              '("@ljharb/eslint-config"
+                "aud"
+                "auto-changelog"
+		"eslint"
+		"nyc"
+		"safe-publish-latest"
+                "tape")))))
+       #:tests? #f))  ; FIXME tests depend on node-tape.
+    (inputs
+     (list node-function-bind node-get-intrinsic))
+    (home-page "https://github.com/ljharb/call-bind")
+    (synopsis "Implementation of Javascript .call.bind")
+    (description "This package provides a robust implementation of the
+.call.bind() in Javascript.")
+    (license license:expat)))
+
 (define-public node-color-name
   (package
     (name "node-color-name")