diff mbox series

[bug#62428,01/14] gnu: Add r-anota2seq.

Message ID 20230324231900.28367-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62428,01/14] gnu: Add r-anota2seq. | expand

Commit Message

Mădălin Ionel Patrașcu March 24, 2023, 11:18 p.m. UTC
* gnu/packages/bioconductor.scm (r-anota2seq): New variable.
---
 gnu/packages/bioconductor.scm | 36 +++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: ef71e3290916583973724316e815cee840c1b6d8
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fe446df67a..37b649a7d6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12069,6 +12069,42 @@  (define-public r-anota
 the data set is suitable for such analysis.")
     (license license:gpl3)))
 
+(define-public r-anota2seq
+  (package
+    (name "r-anota2seq")
+    (version "1.20.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "anota2seq" version))
+       (sha256
+        (base32 "14ggggfa6mdqcb2hfvann9mb66s7a9nxlnh31zblb3mrrjizg1x3"))))
+    (properties `((upstream-name . "anota2seq")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-deseq2
+           r-edger
+           r-limma
+           r-multtest
+           r-qvalue
+           r-rcolorbrewer
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/anota2seq")
+    (synopsis "Transcriptome-wide analysis of translational efficiency")
+    (description
+     "The anota2seq package provides analysis of translational efficiency and
+differential expression analysis for polysome-profiling and ribosome-profiling
+studies (two or more sample classes) quantified by RNA sequencing or
+DNA-microarray.  Polysome-profiling and ribosome-profiling typically generate
+data for two RNA sources, translated mRNA and total mRNA.  Analysis of
+differential expression is used to estimate changes within each RNA source.
+Analysis of translational efficiency aims to identify changes in translation
+efficiency leading to altered protein levels that are independent of total mRNA
+levels or buffering, a mechanism regulating translational efficiency so that
+protein levels remain constant despite fluctuating total mRNA levels.")
+    (license license:gpl3)))
+
 (define-public r-sigpathway
   (package
     (name "r-sigpathway")