diff mbox series

[bug#62428,12/14] gnu: Add r-beaddatapackr.

Message ID 20230324231900.28367-12-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62428,01/14] gnu: Add r-anota2seq. | expand

Commit Message

Mădălin Ionel Patrașcu March 24, 2023, 11:18 p.m. UTC
* gnu/packages/bioconductor.scm (r-beaddatapackr): New variable.
---
 gnu/packages/bioconductor.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7a904d3d08..e7ab9c983c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -17963,6 +17963,26 @@  (define-public r-beadarraysnp
 performs copy number calculations and reports.")
     (license license:gpl2)))
 
+(define-public r-beaddatapackr
+  (package
+    (name "r-beaddatapackr")
+    (version "1.50.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BeadDataPackR" version))
+       (sha256
+        (base32 "0309cvc9aq4nb06zysb7jvzd844pvw6jbjiqwhar6fg01cx255j0"))))
+    (properties `((upstream-name . "BeadDataPackR")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/BeadDataPackR")
+    (synopsis "Compression of Illumina BeadArray data")
+    (description
+     "This package provides functionality for the compression and decompression
+of raw bead-level data from the Illumina BeadArray platform.")
+    (license license:gpl2)))
+
 ;; This package includes files that have been taken from kentutils.  Some
 ;; parts of kentutils are not released under a free license, but this package
 ;; only uses files that are also found in the free parts of kentutils.