diff mbox series

[bug#61838,05/13] gnu: Add r-leidenalg.

Message ID 20230227102850.18782-5-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61838,01/13] gnu: Add r-simplermarkdown. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 27, 2023, 10:28 a.m. UTC
* gnu/packages/cran.scm (r-leidenalg): New variable.
---
 gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index da2b2521a7..3784faa752 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23308,6 +23308,41 @@  (define-public r-leiden
 guaranteeing well-connected communities.\" <arXiv:1810.08473>.")
     (license license:gpl3)))
 
+(define-public r-leidenalg
+  (package
+    (name "r-leidenalg")
+    (version "1.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "leidenAlg" version))
+       (sha256
+        (base32 "1z96zrsms93gspylmficaggb0xj94kq9rg3p2svdbb451jbga9an"))))
+    (properties `((upstream-name . "leidenAlg")))
+    (build-system r-build-system)
+    (inputs
+     (list glpk
+           libxml2))
+    (propagated-inputs
+     (list gmp
+           r-igraph
+           r-matrix
+           r-rcpp
+           r-rcpparmadillo
+           r-rcppeigen
+           r-sccore))
+    (native-inputs (list gfortran))
+    (home-page "https://github.com/kharchenkolab/leidenAlg")
+    (synopsis "Leiden algorithm via an R interface")
+    (description
+     "This package implements an R interface to the Leiden algorithm, an iterative
+community detection algorithm on networks.  The algorithm is designed to converge
+to a partition in which all subsets of all communities are locally optimally assigned,
+yielding communities guaranteed to be connected.  The implementation proves to be
+fast, scales well, and can be run on graphs of millions of nodes (as long as they can
+fit in memory).")
+    (license license:gpl3)))
+
 (define-public r-patchwork
   (package
     (name "r-patchwork")