diff mbox series

[bug#61838,02/13] gnu: Add r-rcppspdlog.

Message ID 20230227102850.18782-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61838,01/13] gnu: Add r-simplermarkdown. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 27, 2023, 10:28 a.m. UTC
* gnu/packages/cran.scm (r-rcppspdlog): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ricardo Wurmus Feb. 27, 2023, 7:12 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/cran.scm (r-rcppspdlog): New variable.
[…]
> +    (synopsis "R and C++ interfaces to 'spdlog' C++ header library for logging")

Please remove the single quotes.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f63112c3be..46b8dbc9ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4992,6 +4992,30 @@  (define-public r-rcppml
 factorization and divisive clustering for large sparse and dense matrices.")
     (license license:gpl2+)))
 
+(define-public r-rcppspdlog
+  (package
+    (name "r-rcppspdlog")
+    (version "0.0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RcppSpdlog" version))
+       (sha256
+        (base32 "1nan0hm49xdl2l1lskm1jf01clfh7aw2v6h57j35qysvg8219fcx"))))
+    (properties `((upstream-name . "RcppSpdlog")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (native-inputs (list r-simplermarkdown))
+    (home-page "https://github.com/eddelbuettel/rcppspdlog")
+    (synopsis "R and C++ interfaces to 'spdlog' C++ header library for logging")
+    (description
+     "The spdlog library is a widely-used and very capable header-only C++ library
+for logging.  This package includes its headers as an R package to permit other R
+packages to deploy it via a simple @code{LinkingTo: RcppSpdlog}.  As of version
+0.0.9, it also provides both simple R logging functions and compiled functions
+callable by other packages.")
+    (license license:gpl2+)))
+
 (define-public r-rcppthread
   (package
     (name "r-rcppthread")