diff mbox series

[bug#61838,01/13] gnu: Add r-simplermarkdown.

Message ID 20230227102850.18782-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61838,01/13] gnu: Add r-simplermarkdown. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 27, 2023, 10:28 a.m. UTC
* gnu/packages/cran.scm (r-simplermarkdown): New variable.
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 5d10644371abd54d0edcd638691113f0a92de743

Comments

Ricardo Wurmus Feb. 27, 2023, 7:10 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/cran.scm (r-simplermarkdown): New variable.

Thanks for the patch.  This package’s DESCRIPTION file says that Pandoc
must be installed and available in the search path, yet this package
does not have pandoc as an input.

Would it be possible to patch the reference to the pandoc executable?
Ricardo Wurmus March 1, 2023, 1:20 p.m. UTC | #2
I’ve applied this series with a number of changes, not limited to the
following:

- moved non-CRAN packages to bioinformatics.scm (r-conospanel, r-p2data)
- reformatted descriptions
- fixed typos
- corrected license of leidenalg
- removed extraneous single quotes

All pushed with the last commit
f01b5299db6031174f05124b843c936388cd872a.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c80e98134a..f63112c3be 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9652,6 +9652,28 @@  (define-public r-signal
 It also includes interpolation functions.")
     (license license:gpl2)))
 
+(define-public r-simplermarkdown
+  (package
+    (name "r-simplermarkdown")
+    (version "0.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "simplermarkdown" version))
+       (sha256
+        (base32 "069pgx5m22rdqa21lyn5zqm9ym3g7w6z1d2wjwms8b1f2cp6266g"))))
+    (properties `((upstream-name . "simplermarkdown")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rjson))
+    (home-page "https://github.com/djvanderlaan/simplermarkdown")
+    (synopsis "Simple engine for generating reports using R")
+    (description
+     "This package runs R-code present in a pandoc markdown file and includes the
+resulting output in the resulting markdown file.  This file can then be converted
+into any of the output formats supported by pandoc.  The package can also be used
+as an engine for writing package vignettes.")
+    (license license:gpl3+)))
+
 (define-public r-gsubfn
   (package
     (name "r-gsubfn")